]> git.pld-linux.org Git - packages/apache-mod_transform.git/blob - apache-mod_transform.spec
- cosmetics
[packages/apache-mod_transform.git] / apache-mod_transform.spec
1 %define         mod_name        transform
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Module to serve XML based content
4 Summary(pl):    Modu³ do udostêpniania dokumentów XML
5 Name:           apache-mod_%{mod_name}
6 Version:        0.4.0
7 Release:        2
8 License:        GPL v2+
9 Group:          Networking/Daemons
10 Source0:        http://www.outoforder.cc/downloads/mod_transform/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  a41ea16eeefb9b798186153b154a1219
12 Source1:        %{name}.conf
13 URL:    http://www.outoforder.cc/projects/apache/mod_transform/
14 BuildRequires:  %{apxs}
15 BuildRequires:  libxml2-devel
16 BuildRequires:  libxslt-devel
17 Requires(post,preun):   %{apxs}
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
21 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR)
22
23 %description
24 mod_transform is a filter module that allows Apache 2.0 to do dynamic
25 XSL Transformations on either static XML documents, or XML documents
26 generated from another Apache module or CGI program.
27
28 %description -l pl
29 mod_transform to modu³ filtra umo¿liwiaj±cy serwerowi Apache 2.0
30 wykonywaæ dynamiczne przekszta³cenia XML na statycznych dokumentach
31 XML lub dokumentach XML generowanych przez inny modu³ Apache'a lub
32 program CGI.
33
34 %prep
35 %setup -q -n mod_%{mod_name}-%{version}
36
37 %build
38 %{__libtoolize}
39 %{__aclocal} -I m4
40 %{__autoconf}
41 %{__autoheader}
42 %{__automake}
43 %configure
44 %{__make}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
49
50 install src/.libs/libmod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
51 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/61_mod_transform.conf
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 if [ -f /var/lock/subsys/httpd ]; then
58         /etc/rc.d/init.d/httpd restart 1>&2
59 fi
60
61 %preun
62 if [ "$1" = "0" ]; then
63         if [ -f /var/lock/subsys/httpd ]; then
64                 /etc/rc.d/init.d/httpd restart 1>&2
65         fi
66 fi
67
68 %files
69 %defattr(644,root,root,755)
70 %doc TODO
71 %attr(755,root,root) %{_pkglibdir}/*
72 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd.conf/*.conf
This page took 0.042347 seconds and 3 git commands to generate.