]> git.pld-linux.org Git - packages/apache-mod_transform.git/blob - apache-mod_transform.spec
- fixed building against new apr
[packages/apache-mod_transform.git] / apache-mod_transform.spec
1 %define         mod_name        transform
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Module to serve XML based content
4 Summary(pl):    Modu³ do udostêpniania dokumentów XML
5 Name:           apache-mod_%{mod_name}
6 Version:        0.4.0
7 Release:        3
8 License:        GPL v2+
9 Group:          Networking/Daemons
10 Source0:        http://www.outoforder.cc/downloads/mod_transform/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  a41ea16eeefb9b798186153b154a1219
12 Source1:        %{name}.conf
13 URL:            http://www.outoforder.cc/projects/apache/mod_transform/
14 BuildRequires:  %{apxs}
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  libtool
18 BuildRequires:  libxml2-devel
19 BuildRequires:  libxslt-devel
20 Requires(post,preun):   %{apxs}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
24 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR)
25
26 %description
27 mod_transform is a filter module that allows Apache 2.0 to do dynamic
28 XSL Transformations on either static XML documents, or XML documents
29 generated from another Apache module or CGI program.
30
31 %description -l pl
32 mod_transform to modu³ filtra umo¿liwiaj±cy serwerowi Apache 2.0
33 wykonywaæ dynamiczne przekszta³cenia XML na statycznych dokumentach
34 XML lub dokumentach XML generowanych przez inny modu³ Apache'a lub
35 program CGI.
36
37 %prep
38 %setup -q -n mod_%{mod_name}-%{version}
39
40 %build
41 %{__perl} -pi -e "s:apr-config:apr-1-config:g" aclocal.m4 m4/apache.m4
42 %{__perl} -pi -e "s:apu-config:apu-1-config:g" aclocal.m4 m4/apache.m4
43 %{__libtoolize}
44 %{__aclocal} -I m4
45 %{__autoconf}
46 %{__autoheader}
47 %{__automake}
48 %configure
49 %{__make}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
54
55 install src/.libs/libmod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
56 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/61_mod_transform.conf
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post
62 if [ -f /var/lock/subsys/httpd ]; then
63         /etc/rc.d/init.d/httpd restart 1>&2
64 fi
65
66 %preun
67 if [ "$1" = "0" ]; then
68         if [ -f /var/lock/subsys/httpd ]; then
69                 /etc/rc.d/init.d/httpd restart 1>&2
70         fi
71 fi
72
73 %files
74 %defattr(644,root,root,755)
75 %doc TODO
76 %attr(755,root,root) %{_pkglibdir}/*
77 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd.conf/*.conf
This page took 0.138299 seconds and 3 git commands to generate.