]> git.pld-linux.org Git - packages/apache-mod_ruby.git/blob - apache-mod_ruby.spec
- updated to 1.2.4
[packages/apache-mod_ruby.git] / apache-mod_ruby.spec
1 %define         mod_name        mod_ruby
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Apache mod_ruby module - embeds the Ruby interpreter into the Apache web server
4 Summary(pl):    Modu³ Apache'a mod_ruby - zapewniaj±cy obs³ugê skryptów rubego przez serwer Apache
5 Name:           apache-%{mod_name}
6 Version:        1.2.4
7 Release:        1
8 Group:          Networking/Daemons
9 License:        BSD-like
10 Source0:        http://www.modruby.net/archive/%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  2b803c021297517eecb3dc6cf77b9534
12 Source1:        %{name}.conf
13 Patch0:         %{name}-struct.patch
14 URL:            http://www.modruby.net/
15 BuildRequires:  apache-devel >= 1.3.3
16 BuildRequires:  %{apxs}
17 BuildRequires:  ruby >= 1:1.6.4
18 Requires(post,preun):   %{apxs}
19 Requires:       apache >= 1.3.3
20 Requires:       ruby >= 1:1.6.4
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR)
24 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
25 %define         ruby_rubylibdir %(ruby -r rbconfig -e 'print Config::CONFIG["rubylibdir"]')
26
27 %description
28 mod_ruby embeds the Ruby interpreter into the Apache web server,
29 allowing Ruby CGI scripts to be executed natively. These scripts will
30 start up much faster than without mod_ruby.
31
32 %description -l pl
33 mod_ruby zapewnia obs³ugê skryptów Ruby'ego bezpo¶rednio z poziomu
34 Apache'a, dziêki czemu bêd± siê one ³adowa³y znacznie szybciej ni¿
35 gdyby by³y wywo³ywane tradycyjnie.
36
37 %prep
38 %setup -q -n %{mod_name}-%{version}
39 %patch0 -p1
40
41 %build
42 ./configure.rb \
43         --with-apr-includes='/usr/include/apr -I/usr/include/apr-util'\
44         --with-apxs=%{apxs}
45 %{__make}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{ruby_rubylibdir}}
51 install %{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/%{mod_name}.so
52
53 # Install the config file
54 install -d $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
55 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/70_mod_ruby.conf
56
57 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %post
63 if [ -f /var/lock/subsys/httpd ]; then
64         /etc/rc.d/init.d/httpd restart 1>&2
65 fi
66
67 %preun
68 if [ "$1" = "0" ]; then
69         if [ -f /var/lock/subsys/httpd ]; then
70                 /etc/rc.d/init.d/httpd restart 1>&2
71         fi
72 fi
73
74 %files
75 %defattr(644,root,root,755)
76 %doc COPYING ChangeLog README.en examples doc/*
77 %lang(ja) %doc README.ja
78 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd.conf/*.conf
79 %attr(755,root,root) %{_pkglibdir}/*
80 %{ruby_rubylibdir}/*
This page took 0.04568 seconds and 3 git commands to generate.