]> git.pld-linux.org Git - packages/apache-mod_qos.git/blame - apache-mod_qos.spec
- more BR
[packages/apache-mod_qos.git] / apache-mod_qos.spec
CommitLineData
ea32b2bf
AM
1%define mod_name qos
2%define apxs /usr/sbin/apxs
3Summary: Apache module: Quality Of Service
4Name: apache-mod_%{mod_name}
5Version: 11.1
6Release: 1
7License: Apache
8Group: Networking/Daemons/HTTP
9Source0: https://downloads.sourceforge.net/project/mod-qos/mod_qos-%{version}.tar.gz
10# Source0-md5: 286d2d2b2f5abae9ccc48fa58f17dda1
11Source1: %{name}.conf
12URL: http://opensource.adnovum.ch/mod_qos/
13BuildRequires: %{apxs}
14BuildRequires: apache-devel >= 2.0.0
1663cdea
AM
15BuildRequires: libpng-devel
16BuildRequires: openssl-devel
17BuildRequires: pcre-devel
ea32b2bf
AM
18BuildRequires: rpmbuild(macros) >= 1.268
19Requires: apache(modules-api) = %apache_modules_api
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%define apacheconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
23%define apachelibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
24
25%description
26mod_qos is a quality of service module for the Apache Web Server. It
27implements control mechanisms that can provide different priority to
28different requests and controls server access based on available
29resources.
30
31%prep
32%setup -q -n mod_%{mod_name}-%{version}
33
34%build
35cd tools
36%{__aclocal}
37%{__autoconf}
38%{__automake}
39%configure \
1663cdea
AM
40 --with-pcre=%{_bindir} \
41 --with-png=%{_bindir} \
42 --with-ssl=%{_prefix}
ea32b2bf
AM
43%{__make}
44cd ..
45
46%{apxs} -c -o mod_qos.la apache2/mod_qos.c
47
48%install
49rm -rf $RPM_BUILD_ROOT
50install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir}}
51
52%{__make} -C tools install \
53 DESTDIR=$RPM_BUILD_ROOT
54
55cp -p .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{apachelibdir}
56cp -p %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/97_mod_%{mod_name}.conf
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%post
62%service -q httpd restart
63
64%postun
65if [ "$1" = "0" ]; then
66 %service -q httpd restart
67fi
68
69%files
70%defattr(644,root,root,755)
71%doc doc/*
72%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*mod_*.conf
73%attr(755,root,root) %{apachelibdir}/*.so
74%attr(755,root,root) %{_bindir}/qs*
This page took 0.082105 seconds and 4 git commands to generate.