]> git.pld-linux.org Git - packages/apache-mod_perl.git/commitdiff
- bcond-remove internal Apache-Test
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 18 Jan 2006 09:23:11 +0000 (09:23 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    apache-mod_perl.spec -> 1.120

apache-mod_perl.spec

index bb5754bc3b3935c396a2755b40eaab2223a165a9..16a8f9fb3a3b37993102320a0c1c2437b39df69f 100644 (file)
@@ -1,6 +1,8 @@
 # TODO:
 # - separate perl-things from apache libs and configs (needed for some buildings)
 # - separate devel things from runtime things (apache-mod_perl-2.0.2-2 marks perl-ExtUtils-MakeMaker-6.25_08-1 (cap perl(ExtUtils::Install)))
+%bcond_without internal_test   # use internal Apache-Test
+#
 %include       /usr/lib/rpm/macros.perl
 %define        apxs    /usr/sbin/apxs
 %define        apache_test_version     1.27-2
@@ -39,7 +41,7 @@ BuildRequires:        apr-util-devel >= 1:1.0.0
 BuildRequires: expat-devel
 BuildRequires: gdbm-devel
 BuildRequires: openldap-devel >= 2.3.0
-#BuildRequires:        perl-Apache-Test = %{apache_test_version}
+%{!?internal_test:BuildRequires:       perl-Apache-Test = %{apache_test_version}}
 BuildRequires: perl-devel >= 1:5.8.2
 BuildRequires: rpm-perlprov >= 3.0.3-16
 %requires_eq_to        apache apache-devel
@@ -49,7 +51,7 @@ Provides:     apache(mod_perl)
 # What's this mod_perl_hooks for?
 Provides:      perl(mod_perl_hooks)
 # not sure is this neccessary
-#Requires:     perl-Apache-Test = %{apache_test_version}
+%{!?internal_test:Requires:    perl-Apache-Test = %{apache_test_version}}
 Obsoletes:     mod_perl
 Obsoletes:     mod_perl-common
 Conflicts:     perl-modules < 1:5.8.6-6
@@ -204,6 +206,7 @@ building XS modules that use mod_perl.
 %setup -q -n mod_perl-%{version}
 %patch0 -p1
 
+if %{without internal_test}
 system=$(%{__perl} -MApache::Test -e 'print Apache::Test->VERSION')
 bundled=$(%{__perl} -IApache-Test/lib -MApache::Test -e 'print Apache::Test->VERSION')
 if [ "$system" != "$bundled" ]; then
@@ -211,6 +214,7 @@ if [ "$system" != "$bundled" ]; then
        exit 1
 fi
 rm -rf Apache-Test
+%endif
 
 %build
 %{__perl} Makefile.PL \
This page took 0.120008 seconds and 4 git commands to generate.