]> git.pld-linux.org Git - packages/apache-mod_perl.git/blob - apache-mod_perl.spec
- added apache(EAPI) to Prereq,
[packages/apache-mod_perl.git] / apache-mod_perl.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        A Perl interpreter for the Apache Web server
3 Summary(pl):    Interpreter perla dla serwera WWW Apache
4 Name:           apache-mod_perl
5 Version:        1.25
6 Release:        4
7 License:        GPL
8 Group:          Networking/Daemons
9 Group(de):      Netzwerkwesen/Server
10 Group(pl):      Sieciowe/Serwery
11 Source0:        http://perl.apache.org/dist/mod_perl-%{version}.tar.gz
12 Patch0:         apache-perl-rh.patch
13 # from ftp://ftp.kddlabs.co.jp/Linux/packages/Kondara/pub/Jirai/
14 Patch1:         mod_perl-v6.patch
15 BuildRequires:  apache(EAPI)-devel
16 BuildRequires:  gdbm-devel
17 BuildRequires:  perl >= 5.6.1
18 BuildRequires:  perl-B-Graph
19 BuildRequires:  perl-BSD-Resource
20 BuildRequires:  perl-Devel-Symdump
21 BuildRequires:  perl-HTML-Parser
22 BuildRequires:  perl-MIME-Base64
23 BuildRequires:  perl-URI
24 BuildRequires:  perl-libwww
25 BuildRequires:  rpm-perlprov >= 3.0.3-16
26 Prereq:         apache(EAPI)
27 Provides:       perl(mod_perl_hooks)
28 Provides:       mod_perl
29 Obsoletes:      mod_perl
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Mod_perl incorporates a Perl interpreter into the Apache web server,
34 so that the Apache web server can directly execute Perl code. Mod_perl
35 links the Perl runtime library into the Apache web server and provides
36 an object-oriented Perl interface for Apache's C language API. The end
37 result is a quicker CGI script turnaround process, since no external
38 Perl interpreter has to be started.
39
40 %description -l pl
41 Mod_perl jest modu³em, który wyposa¿a serwer Apache w interpreter
42 perla, umo¿liwiaj±c w ten sposób bezpo¶rednie wykonywanie kodu perla
43 przez serwer bez potrzeby anga¿owania zewnêtrznego interpretera, co
44 przyspiesza procesy zwi±zane z uruchamianiem skryptów CGI.
45
46 %prep
47 %setup  -q -n mod_perl-%{version}
48 %patch0 -p1
49 %patch1 -p1
50
51 %build
52 perl Makefile.PL \
53         USE_APXS=1 \
54         WITH_APXS=/usr/sbin/apxs \
55         EVERYTHING=1 \
56         PERL_STACKED_HANDLERS=1
57
58 (cd apaci; ln -s ../src/modules .; chmod +x find_source)
59 %{__make}
60
61 (cd faq; make)
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT{%{_libdir}/apache,/home/httpd/manual/mod}
66
67 %{__make} pure_install DESTDIR=$RPM_BUILD_ROOT
68         
69 install apaci/libperl.so $RPM_BUILD_ROOT%{_libdir}/apache
70 install htdocs/manual/mod/mod_perl.html \
71         $RPM_BUILD_ROOT/home/httpd/manual/mod
72
73 gzip -9nf README INSTALL ToDo
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post
79 /usr/sbin/apxs -e -a -n perl %{_libexecdir}/libperl.so 1>&2
80 if [ -f /var/lock/subsys/httpd ]; then
81         /etc/rc.d/init.d/httpd restart 1>&2
82 else
83         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
84 fi
85
86 %preun
87 if [ "$1" = "0" ]; then
88         /usr/sbin/apxs -e -A -n perl %{_libexecdir}/libperl.so 1>&2
89         if [ -f /var/lock/subsys/httpd ]; then
90                 /etc/rc.d/init.d/httpd stop 1>&2
91         fi
92 fi
93
94
95 %files
96 %defattr(644,root,root,755)
97 %doc *.gz faq/*.html apache-modlist.html eg
98 %doc /home/httpd/manual/mod/*html
99
100 %attr(755,root,root) %{_libdir}/apache/*.so
101
102 %{perl_sitearch}/*.pm
103 %{perl_sitearch}/*.PL
104
105 %{perl_sitearch}/Apache/*.pm
106 %{perl_sitearch}/Apache/Constants
107 %{perl_sitearch}/Bundle/*.pm
108 %{perl_sitearch}/auto/mod_perl
109 %dir %{perl_sitearch}/auto/Apache/Leak
110 %dir %{perl_sitearch}/auto/Apache/Symbol
111
112 %{perl_sitearch}/auto/*/*/*.bs
113 %attr(755,root,root) %{perl_sitearch}/auto/*/*/*.so
114
115 %{_mandir}/man3/*
This page took 0.050999 seconds and 4 git commands to generate.