]> git.pld-linux.org Git - packages/apache-mod_perl.git/blob - apache-mod_perl.spec
- release 2
[packages/apache-mod_perl.git] / apache-mod_perl.spec
1 %include        /usr/lib/rpm/macros.perl
2 Summary:        A Perl interpreter for the Apache Web server
3 Summary(pl):    Interpreter perla dla serwera WWW Apache
4 Name:           apache-mod_perl
5 Version:        1.25
6 Release:        2
7 License:        GPL
8 Group:          Networking/Daemons
9 Group(pl):      Sieciowe/Serwery
10 Source0:        http://perl.apache.org/dist/mod_perl-%{version}.tar.gz
11 Patch0:         apache-perl-rh.patch
12 # from ftp://ftp.kddlabs.co.jp/Linux/packages/Kondara/pub/Jirai/
13 Patch1:         mod_perl-v6.patch
14 BuildRequires:  rpm-perlprov >= 3.0.3-16
15 BuildRequires:  perl >= 5.005_03-14
16 BuildRequires:  apache-devel
17 BuildRequires:  gdbm-devel
18 BuildRequires:  perl-libwww
19 BuildRequires:  perl-HTML-Parser
20 BuildRequires:  perl-MIME-Base64
21 BuildRequires:  perl-BSD-Resource
22 BuildRequires:  perl-B-Graph
23 BuildRequires:  perl-Devel-Symdump
24 BuildRequires:  perl-URI
25 %requires_eq    perl
26 Requires:       %{perl_sitearch}
27 Requires:       apache
28 Provides:       perl(mod_perl_hooks)
29 Provides:       mod_perl
30 Obsoletes:      mod_perl
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Mod_perl incorporates a Perl interpreter into the Apache web server,
35 so that the Apache web server can directly execute Perl code. Mod_perl
36 links the Perl runtime library into the Apache web server and provides
37 an object-oriented Perl interface for Apache's C language API. The end
38 result is a quicker CGI script turnaround process, since no external
39 Perl interpreter has to be started.
40
41 %description -l pl
42 Mod_perl jest modu³em, który wyposa¿a serwer Apache w interpreter
43 perla, umo¿liwiaj±c w ten sposób bezpo¶rednie wykonywanie kodu perla
44 przez serwer bez potrzeby anga¿owania zewnêtrznego interpretera, co
45 przyspiesza procesy zwi±zane z uruchamianiem skryptów CGI.
46
47 %prep
48 %setup  -q -n mod_perl-%{version}
49 %patch0 -p1
50 %patch1 -p1
51
52 %build
53 perl Makefile.PL \
54         USE_APXS=1 \
55         WITH_APXS=%{_sbindir}/apxs \
56         EVERYTHING=1 \
57         PERL_STACKED_HANDLERS=1
58
59 (cd apaci; ln -s ../src/modules .; chmod +x find_source)
60 %{__make}
61
62 (cd faq; make)
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT{%{_libdir}/apache,/home/httpd/html/manual/mod}
67
68 %{__make} pure_install DESTDIR=$RPM_BUILD_ROOT
69         
70 install -m 755 apaci/libperl.so $RPM_BUILD_ROOT%{_libdir}/apache
71 install htdocs/manual/mod/mod_perl.html \
72         $RPM_BUILD_ROOT/home/httpd/html/manual/mod
73
74 find $RPM_BUILD_ROOT -name \*.so -exec strip --strip-unneeded {} \;
75
76 (
77         cd $RPM_BUILD_ROOT%{perl_sitearch}/auto/mod_perl/
78         mv .packlist .packlist.old
79         sed -e "s|$RPM_BUILD_ROOT||g" < .packlist.old > .packlist
80         rm -f .packlist.old
81 )
82
83 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man3/* \
84         README INSTALL ToDo
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post
90 %{_sbindir}/apxs -e -a -n perl %{_libexecdir}/libperl.so 1>&2
91 if [ -f /var/lock/subsys/httpd ]; then
92    /etc/rc.d/init.d/httpd restart 1>&2
93 fi
94
95 %preun
96 %{_sbindir}/apxs -e -A -n perl %{_libexecdir}/libperl.so 1>&2
97
98 if [ -f /var/lock/subsys/httpd ]; then
99         /etc/rc.d/init.d/httpd stop 1>&2
100 fi
101
102
103 %files
104 %defattr(644,root,root,755)
105 %doc {README,INSTALL,ToDo}.gz faq/*.html apache-modlist.html eg
106 %doc /home/httpd/html/manual/mod/*html
107
108 %attr(755,root,root) %{_libdir}/apache/*.so
109
110 %{perl_sitearch}/*.pm
111 %{perl_sitearch}/*.pod
112 %{perl_sitearch}/*.PL
113
114 %{perl_sitearch}/Apache/*.pm
115 %{perl_sitearch}/Apache/Constants
116 %{perl_sitearch}/Bundle/*.pm
117 %{perl_sitearch}/auto/mod_perl
118 %dir %{perl_sitearch}/auto/Apache/Leak
119 %dir %{perl_sitearch}/auto/Apache/Symbol
120
121 %{perl_sitearch}/auto/*/*/*.bs
122 %attr(755,root,root) %{perl_sitearch}/auto/*/*/*.so
123
124 %{_mandir}/man3/*
This page took 0.038403 seconds and 4 git commands to generate.