]> git.pld-linux.org Git - packages/apache-mod_pagespeed.git/commitdiff
- fix use of latest version
authorElan Ruusamäe <glen@pld-linux.org>
Sat, 8 Oct 2011 10:57:58 +0000 (10:57 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    get-source.sh -> 1.3

get-source.sh

index 5c47f46a8f53d0c1fac05acb6cd22f2aa329a14e..5f0346c2c006b8c4c244fb58df3429de990faf02 100644 (file)
@@ -6,18 +6,11 @@
 pkg=modpagespeed
 baseurl=http://modpagespeed.googlecode.com/svn
 # leave empty to use latest tag, or "trunk" for trunk
-version=0.9.18.9
+version=
 spec=apache-mod_pagespeed.spec
 
 # abort on errors
 set -e
-
-# gclient needs python 2.6
-if python -c "import sys; sys.exit(sys.version[:3] > '2.6')"; then
-       echo >&2 "Need python >= 2.6 for gclient"
-       exit 1
-fi
-
 # work in package dir
 dir=$(dirname "$0")
 cd "$dir"
@@ -29,7 +22,7 @@ fi
 if [ -z "$version" ]; then
        echo "Looking for latest version..."
        version=$(svn ls $baseurl/tags/ | sort -V | tail -n1)
-       version=${version#/}
+       version=${version%/}
 fi
 
 if [ "$version" = "trunk" ]; then
@@ -42,6 +35,12 @@ else
        tarball=$pkg-$version.tar.bz2
 fi
 
+# gclient needs python 2.6
+if python -c "import sys; sys.exit(sys.version[:3] > '2.6')"; then
+       echo >&2 "Need python >= 2.6 for gclient"
+       exit 1
+fi
+
 wget -c http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
 test -d depot_tools || tar xzf depot_tools.tar.gz
 
This page took 0.036091 seconds and 4 git commands to generate.