]> git.pld-linux.org Git - packages/apache-mod_pagespeed.git/commitdiff
- skip hooks, we generate makefiles in .spec
authorElan Ruusamäe <glen@pld-linux.org>
Sat, 7 Jul 2012 20:17:20 +0000 (20:17 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    get-source.sh -> 1.8

get-source.sh

index c9006126cd318d4f20fc9ee57224e537e10764f7..68c1b61688f21891591a866f15c6d3c9eb661fba 100644 (file)
@@ -67,17 +67,17 @@ gclient=$topdir/gclient.conf
 install -d $pkg
 cd $pkg
 
 install -d $pkg
 cd $pkg
 
-if [ ! -f .gclient ]; then
-       if [ ! -f $gclient ]; then
-               ../depot_tools/gclient config $svnurl --gclientfile=$gclient
-       fi
-       cp $gclient .gclient
+if [ ! -f $gclient ]; then
+       # create initial config that can be later modified
+       ../depot_tools/gclient config $svnurl --gclientfile=$gclient
 fi
 
 fi
 
+cp $gclient .gclient
+
 # emulate gclient config, preserving our deps
 sed -i -re '/"url"/ s,"http[^"]+","'$svnurl'",' .gclient
 
 # emulate gclient config, preserving our deps
 sed -i -re '/"url"/ s,"http[^"]+","'$svnurl'",' .gclient
 
-../depot_tools/gclient sync -v
+../depot_tools/gclient sync --nohooks -v
 
 # Populate the LASTCHANGE file template as we will not include VCS info in tarball
 (cd src/build && svnversion > LASTCHANGE.in)
 
 # Populate the LASTCHANGE file template as we will not include VCS info in tarball
 (cd src/build && svnversion > LASTCHANGE.in)
This page took 0.064822 seconds and 4 git commands to generate.