]> git.pld-linux.org Git - packages/apache-mod_pagespeed.git/commitdiff
use system yasm
authorElan Ruusamäe <glen@delfi.ee>
Mon, 15 Dec 2014 22:03:19 +0000 (00:03 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 15 Dec 2014 22:04:25 +0000 (00:04 +0200)
apache-mod_pagespeed.spec
gclient.conf
get-source.sh

index f0e286a40c387801d247ea12868d774c36774cbf..618ebc342dd08b1b524a5fbf5f9b850a8936c938 100644 (file)
@@ -21,11 +21,11 @@ Name:               apache-mod_%{mod_name}
 # beta: 1.9.32.2-beta
 # stable: 1.8.31.5
 Version:       1.8.31.5
 # beta: 1.9.32.2-beta
 # stable: 1.8.31.5
 Version:       1.8.31.5
-Release:       0.7
+Release:       0.10
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
 Source0:       modpagespeed-%{version}.tar.xz
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
 Source0:       modpagespeed-%{version}.tar.xz
-# Source0-md5: 0ec574731370f3da33fd16f536174050
+# Source0-md5: 9aefd5719a9b7946106b625dc7ecd2aa
 Source1:       get-source.sh
 Source2:       gclient.conf
 Patch0:                system-libs.patch
 Source1:       get-source.sh
 Source2:       gclient.conf
 Patch0:                system-libs.patch
@@ -44,6 +44,7 @@ BuildRequires:        opencv-devel >= 2.3.1
 BuildRequires: openssl-devel
 BuildRequires: pkgconfig
 BuildRequires: python-devel >= 1:2.6
 BuildRequires: openssl-devel
 BuildRequires: pkgconfig
 BuildRequires: python-devel >= 1:2.6
+BuildRequires: yasm
 # This version of gyp is new enough that it knows to use make for Linux 3.x
 # and FreeBSD, but old enough that 'type': 'settings' works and
 # LINKER_SUPPORTS_ICF hasn't been removed yet.
 # This version of gyp is new enough that it knows to use make for Linux 3.x
 # and FreeBSD, but old enough that 'type': 'settings' works and
 # LINKER_SUPPORTS_ICF hasn't been removed yet.
@@ -99,6 +100,7 @@ CXX="%{__cxx}" \
        -Duse_system_libpng=1 \
        -Duse_system_opencv=1 \
        -Duse_system_openssl=1 \
        -Duse_system_libpng=1 \
        -Duse_system_opencv=1 \
        -Duse_system_openssl=1 \
+       -Duse_system_yasm=1 \
        -Duse_system_zlib=1 \
        -Dsystem_include_path_apr=%{_includedir}/apr \
        -Dsystem_include_path_aprutil=%{_includedir}/apr-util \
        -Duse_system_zlib=1 \
        -Dsystem_include_path_apr=%{_includedir}/apr \
        -Dsystem_include_path_aprutil=%{_includedir}/apr-util \
index a71c6d70b7053b3f02b4167ee9b908caafd46c62..09064af811123b55f2b2f70ff7a36e80850b14f4 100644 (file)
@@ -27,6 +27,11 @@ solutions = [{
                # need gyp <= @1175
                "src/tools/gyp": None,
 
                # need gyp <= @1175
                "src/tools/gyp": None,
 
+               "src/third_party/openssl": None,
+
+               "src/third_party/libjpeg_turbo/yasm": None,
+               "src/third_party/libjpeg_turbo/yasm/source/patched-yasm": None,
+
                # need .gyp file
 #              "src/third_party/protobuf": None,
 
                # need .gyp file
 #              "src/third_party/protobuf": None,
 
@@ -43,6 +48,10 @@ solutions = [{
 
                "src/build/mac":  None,
                "src/build/win":  None,
 
                "src/build/mac":  None,
                "src/build/win":  None,
+               "src/tools/clang": None,
+
+               # need build/ios/mac_build.gypi
+#              "src/build/ios": None,
 
                # as we have no tests, just keep checkouts and tarball smaller
 #              "src/testing": None,
 
                # as we have no tests, just keep checkouts and tarball smaller
 #              "src/testing": None,
index 7ce1a4d99e0f67a97189e789b9c395f9b1365903..b5676abacdd6594931986347b79a99990ecedb65 100755 (executable)
@@ -105,6 +105,15 @@ almost_strip_dirs \
        third_party/instaweb/ \
        third_party/openssl/ \
 
        third_party/instaweb/ \
        third_party/openssl/ \
 
+# some more unneeded files for build
+rm -r third_party/chromium/src/net
+rm -r third_party/chromium/src/chrome
+rm -r net/instaweb/rewriter/testdata
+
+# build/linux and third_party/chromium/src/build/linux are same dirs, the latter is not usedc
+#rm -r third_party/chromium/src/build/linux
+#third_party/chromium/src/build/linux
+
 # Populate the LASTCHANGE file template as we will not include VCS info in tarball
 ./build/lastchange.sh . -o LASTCHANGE.in
 
 # Populate the LASTCHANGE file template as we will not include VCS info in tarball
 ./build/lastchange.sh . -o LASTCHANGE.in
 
This page took 0.060312 seconds and 4 git commands to generate.