]> git.pld-linux.org Git - packages/apache-mod_pagespeed.git/blobdiff - apache-mod_pagespeed.spec
build with system icu
[packages/apache-mod_pagespeed.git] / apache-mod_pagespeed.spec
index 0dbd77c0d9a43b9b419fd14a2348ac813418935d..f0e286a40c387801d247ea12868d774c36774cbf 100644 (file)
@@ -1,61 +1,69 @@
+#
+# Conditional build:
+%bcond_without verbose         # verbose build (V=1)
+
 # NOTE
-# - use make < 3.82 (from th-obsolete) to hack on code, because 3.82
-#   invalidates built objects and it's annoying to wait if all is recompiled
-#   each time you invoke make
+# - relase notes: https://developers.google.com/speed/pagespeed/module/release_notes
+# - http://code.google.com/p/modpagespeed/wiki/HowToBuild
+# - http://wiki.mediatemple.net/w/(dv)_HOWTO:_Install_mod_pagespeed
 # TODO
-# - c++ errors on 64bit/32bit gcc 4.5.1-4:
-#   /usr/include/c++/4.5.1/bits/stl_map.h:87:5:   instantiated from here
-#   /usr/include/c++/4.5.1/bits/stl_pair.h:77:11: error: ‘std::pair<_T1, _T2>::second’ has incomplete type
-#   ./net/instaweb/util/public/cache_interface.h:28:7: error: forward declaration of ‘struct net_instaweb::SharedString’
-#   make[1]: *** [out/Release/obj.target/mod_pagespeed_test/net/instaweb/util/cache_fetcher_test.o] Error 1
-# - sizeof(apr_int32_t) == sizeof(apr_int64_t) on 32bit (!?!):
-#   third_party/apache/apr/src/strings/apr_snprintf.c: In function 'conv_os_thread_t':
-#   third_party/apache/apr/src/strings/apr_snprintf.c:500:5: error: duplicate case value
-#   third_party/apache/apr/src/strings/apr_snprintf.c:498:5: error: previously used here
-#   third_party/apache/apr/src/strings/apr_snprintf.c: In function 'conv_os_thread_t_hex':
-#   third_party/apache/apr/src/strings/apr_snprintf.c:671:5: error: duplicate case value
-#   third_party/apache/apr/src/strings/apr_snprintf.c:669:5: error: previously used here
+# - add unit tests running
 # - possible sysdeps (uses release tags)
 #  "serf_src": "http://serf.googlecode.com/svn/tags/0.3.1",
-#  "apr_src": "http://svn.apache.org/repos/asf/apr/apr/tags/1.4.2",
-#  "aprutil_src": "http://svn.apache.org/repos/asf/apr/apr-util/tags/1.3.9",
-#  "apache_httpd_src": "http://svn.apache.org/repos/asf/httpd/httpd/tags/2.2.15",
-#  "opencv_src": "https://code.ros.org/svn/opencv/tags/2.1",
 #  "gflags_root": "http://google-gflags.googlecode.com/svn/tags/gflags-1.3/src",
 #  "google_sparsehash_root": "http://google-sparsehash.googlecode.com/svn/tags/sparsehash-1.8.1/src",
+#  protobuf_lite
 
-%define                svndate 20101104
-%define                rel             0.1
 %define                mod_name        pagespeed
-%define        apxs            %{_sbindir}/apxs
+%define                apxs            %{_sbindir}/apxs
 Summary:       Apache module for rewriting web pages to reduce latency and bandwidth
 Name:          apache-mod_%{mod_name}
-Version:       0.9.0.0
-Release:       0.1
+# beta: 1.9.32.2-beta
+# stable: 1.8.31.5
+Version:       1.8.31.5
+Release:       0.7
 License:       Apache v2.0
 Group:         Networking/Daemons/HTTP
-# svn co http://src.chromium.org/svn/trunk/tools/depot_tools
-# install -d modpagespeed
-# cd modpagespeed
-# ../depot_tools/gclient config http://modpagespeed.googlecode.com/svn/trunk/src
-# ../depot_tools/gclient sync
-# Populate the LASTCHANGE file template as we no longer have the VCS files at this point
-# (cd src/build && svnversion > LASTCHANGE.in)
-# cd ..
-# tar -cjf modpagespeed-$(date +%Y%m%d).tar.bz2 --exclude-vcs modpagespeed
-# ../dropin modpagespeed-$(date +%Y%m%d).tar.bz2 &
-Source0:       modpagespeed-%{svndate}.tar.bz2
-# Source0-md5: 1640f3c7226ffd3ba4a67f0064241495
-URL:           http://code.google.com/p/modpagespeed/
+Source0:       modpagespeed-%{version}.tar.xz
+# Source0-md5: 0ec574731370f3da33fd16f536174050
+Source1:       get-source.sh
+Source2:       gclient.conf
+Patch0:                system-libs.patch
+Patch2:                bug-632.patch
+Patch4:                no-dev-stdout.patch
+URL:           https://developers.google.com/speed/pagespeed/module
 BuildRequires: %{apxs}
 BuildRequires: apache-devel >= 2.2
+BuildRequires: bash
+BuildRequires: glib2-devel
+BuildRequires: gperf
+BuildRequires: libicu-devel
+BuildRequires: libselinux-devel
+BuildRequires: libstdc++-devel >= 5:4.1
+BuildRequires: opencv-devel >= 2.3.1
+BuildRequires: openssl-devel
+BuildRequires: pkgconfig
+BuildRequires: python-devel >= 1:2.6
+# This version of gyp is new enough that it knows to use make for Linux 3.x
+# and FreeBSD, but old enough that 'type': 'settings' works and
+# LINKER_SUPPORTS_ICF hasn't been removed yet.
+BuildRequires: python-gyp >= 0.1-0.svn1602.1
 BuildRequires: rpmbuild(macros) >= 1.268
+BuildRequires: tar >= 1:1.22
+BuildRequires: util-linux
+BuildRequires: xz
+BuildRequires: zlib-devel
 Requires:      apache(modules-api) = %apache_modules_api
+Requires:      apache-mod_authz_host
+Requires:      apache-mod_headers
 Suggests:      apache-mod_deflate
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
-%define                _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
+%define                _pkgrootdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
+%define                _sysconfdir     %{_pkgrootdir}/conf.d
+%define                htdocsdir       %(%{apxs} -q htdocsdir 2>/dev/null)
+%define                cachedir        %(%{apxs} -q proxycachedir 2>/dev/null)/mod_%{mod_name}
 
 %description
 mod_pagespeed automates the application of those rules in an Apache
@@ -65,18 +73,39 @@ by Page Speed can be used without having to change the way the web
 site is maintained.
 
 %prep
-%setup -q -n modpagespeed
-
-cat > apache.conf <<EOF
-LoadModule %{mod_name}_module  modules/mod_%{mod_name}.so > apache.conf
+%setup -q -n modpagespeed-%{version}
+%patch0 -p2
+%patch2 -p1
+%patch4 -p1
 
-$(cat src/install/common/pagespeed.conf.template)
-EOF
+rm -r third_party/icu/source
+rm -r third_party/icu/genfiles
+install -d third_party/icu/source/{common,i18n}
+ln -s %{_includedir}/unicode third_party/icu/source/i18n/unicode
+ln -s %{_includedir}/unicode third_party/icu/source/common/unicode
 
 %build
-cat > Makefile <<'EOF'
-default:
-       $(MAKE) -C src \
+# re-gen makefiles
+CC="%{__cc}" \
+CXX="%{__cxx}" \
+%{__python} build/gyp_chromium \
+       --format=make \
+       --depth=. \
+       build/all.gyp \
+       -Duse_openssl=1 \
+       -Duse_system_apache_dev=1 \
+       -Duse_system_icu=1 \
+       -Duse_system_libjpeg=1 \
+       -Duse_system_libpng=1 \
+       -Duse_system_opencv=1 \
+       -Duse_system_openssl=1 \
+       -Duse_system_zlib=1 \
+       -Dsystem_include_path_apr=%{_includedir}/apr \
+       -Dsystem_include_path_aprutil=%{_includedir}/apr-util \
+       -Dsystem_include_path_httpd=%{_includedir}/apache \
+       %{nil}
+
+%{__make} mod_pagespeed js_minify css_minify_main \
        BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
        %{?with_verbose:V=1} \
        CC="%{__cc}" \
@@ -86,14 +115,36 @@ default:
        LINK.host="%{__cxx}" \
        CFLAGS="%{rpmcflags} %{rpmcppflags}" \
        CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
-EOF
-%{__make}
+       %{nil}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
-install -p mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
-cp -a apache.conf $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir},%{_bindir},%{cachedir}}
+
+%{__make} -j1 -C install staging_except_module \
+       APACHE_ROOT=%{_pkgrootdir} \
+       APACHE_MODULES=modules \
+       APACHE_DOC_ROOT=%{htdocsdir} \
+       MOD_PAGESPEED_CACHE=%{cachedir} \
+       MOD_PAGESPEED_STATS_LOG=/var/log/httpd/mod_pagespeed_stats.log \
+       STAGING_DIR=staging
+
+out=out/%{!?debug:Release}%{?debug:Debug}
+install -p $out/libmod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
+install -p $out/js_minify $RPM_BUILD_ROOT%{_bindir}/pagespeed_js_minify
+install -p $out/css_minify_main $RPM_BUILD_ROOT%{_bindir}/pagespeed_css_minify
+
+cd install/staging
+cat > $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf <<EOF
+LoadModule %{mod_name}_module  modules/mod_%{mod_name}.so
+
+$(cat pagespeed.conf)
+EOF
+
+cp -p pagespeed_libraries.conf $RPM_BUILD_ROOT%{_sysconfdir}/91_mod_%{mod_name}_libraries.conf
+
+install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+cp -a mod_pagespeed_example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -109,4 +160,9 @@ fi
 %files
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}_libraries.conf
+%attr(755,root,root) %{_bindir}/pagespeed_css_minify
+%attr(755,root,root) %{_bindir}/pagespeed_js_minify
 %attr(755,root,root) %{_pkglibdir}/mod_%{mod_name}.so
+%{_examplesdir}/%{name}-%{version}
+%dir %attr(770,root,http) %{cachedir}
This page took 0.071067 seconds and 4 git commands to generate.