]> git.pld-linux.org Git - packages/apache-mod_pagespeed.git/blame - apache-mod_pagespeed.spec
- fix BRs
[packages/apache-mod_pagespeed.git] / apache-mod_pagespeed.spec
CommitLineData
757b3ba5
ER
1#
2# Conditional build:
42a31ab3 3%bcond_without verbose # verbose build (V=1)
757b3ba5 4
b6a5d8d0 5# NOTE
757b3ba5 6# - http://code.google.com/p/modpagespeed/wiki/HowToBuild
eb743e9a 7# - http://wiki.mediatemple.net/w/(dv)_HOWTO:_Install_mod_pagespeed
b6a5d8d0 8# TODO
757b3ba5 9# - add unit tests running
b6a5d8d0
ER
10# - possible sysdeps (uses release tags)
11# "serf_src": "http://serf.googlecode.com/svn/tags/0.3.1",
b6a5d8d0
ER
12# "gflags_root": "http://google-gflags.googlecode.com/svn/tags/gflags-1.3/src",
13# "google_sparsehash_root": "http://google-sparsehash.googlecode.com/svn/tags/sparsehash-1.8.1/src",
b74b29a5 14# protobuf_lite
24f1647c
ER
15
16%if "%{pld_release}" == "ac"
17# add suffix, but allow ccache, etc in ~/.rpmmacros
18%{expand:%%define __cc %(echo '%__cc' | sed -e 's,-gcc,-gcc4,')}
19%{expand:%%define __cxx %(echo '%__cxx' | sed -e 's,-g++,-g++4,')}
20%{expand:%%define __cpp %(echo '%__cpp' | sed -e 's,-gcc,-gcc4,')}
21%endif
22
08710a2f
ER
23%define mod_name pagespeed
24%define apxs %{_sbindir}/apxs
25Summary: Apache module for rewriting web pages to reduce latency and bandwidth
26Name: apache-mod_%{mod_name}
ce5a7d18
ER
27Version: 1.5.27.2
28Release: 1
08710a2f
ER
29License: Apache v2.0
30Group: Networking/Daemons/HTTP
4623c72a 31Source0: modpagespeed-%{version}.tar.xz
ce5a7d18 32# Source0-md5: fa8d6a80fc4ca7f929910fa4eeb4a941
b74b29a5 33Source1: get-source.sh
5a3e561c 34Source2: gclient.conf
42a31ab3
ER
35Patch0: system-libs.patch
36Patch1: gcc-headers.patch
1a9213c5 37Patch2: bug-632.patch
b6382d61 38Patch3: opencv.patch
b74b29a5 39URL: https://developers.google.com/speed/pagespeed/
08710a2f
ER
40BuildRequires: %{apxs}
41BuildRequires: apache-devel >= 2.2
42a31ab3 42BuildRequires: glib2-devel
3f27b998 43BuildRequires: gperf
42a31ab3 44BuildRequires: libselinux-devel
b74b29a5 45BuildRequires: libstdc++-devel >= 5:4.1
4623c72a 46BuildRequires: opencv-devel >= 2.3.1
42a31ab3 47BuildRequires: openssl-devel
3f27b998 48BuildRequires: pkgconfig
757b3ba5 49BuildRequires: python-devel >= 1:2.6
4623c72a
ER
50# This version of gyp is new enough that it knows to use make for Linux 3.x
51# and FreeBSD, but old enough that 'type': 'settings' works and
52# LINKER_SUPPORTS_ICF hasn't been removed yet.
3fbdacfc 53BuildRequires: python-gyp >= 0.1-0.svn1602.1
08710a2f 54BuildRequires: rpmbuild(macros) >= 1.268
4623c72a 55BuildRequires: tar >= 1:1.22
2ddcd200 56BuildRequires: util-linux
4623c72a 57BuildRequires: xz
42a31ab3 58BuildRequires: zlib-devel
24f1647c
ER
59# gcc4 might be installed, but not current __cc
60%if "%(echo %{cc_version} | cut -d. -f1,2)" < "4.0"
61BuildRequires: __cc >= 4.0
62%endif
08710a2f 63Requires: apache(modules-api) = %apache_modules_api
e5171f2e 64Requires: apache-mod_authz_host
3f27b998 65Requires: apache-mod_headers
b6a5d8d0 66Suggests: apache-mod_deflate
08710a2f
ER
67BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
06daee42
ER
70%define _pkgrootdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
71%define _sysconfdir %{_pkgrootdir}/conf.d
72%define htdocsdir %(%{apxs} -q htdocsdir 2>/dev/null)
73%define cachedir %(%{apxs} -q proxycachedir 2>/dev/null)/mod_%{mod_name}
08710a2f
ER
74
75%description
76mod_pagespeed automates the application of those rules in an Apache
77server. HTML, CSS, JavaScript, and images are changed dynamically
78during the web serving process, so that the best practices recommended
79by Page Speed can be used without having to change the way the web
80site is maintained.
81
82%prep
5bdfa704
ER
83%setup -q -n modpagespeed-%{version}
84%patch0 -p2
85%patch1 -p2
ce5a7d18 86%patch2 -p1
b6382d61 87%patch3 -p3
08710a2f
ER
88
89%build
eb743e9a 90# re-gen makefiles
e62ba6cb
ER
91CC="%{__cc}" \
92CXX="%{__cxx}" \
5bdfa704
ER
93%{__python} build/gyp_chromium \
94 --format=make \
95 --depth=. \
96 build/all.gyp \
42a31ab3
ER
97 -Duse_openssl=1 \
98 -Duse_system_apache_dev=1 \
99 -Duse_system_libjpeg=1 \
100 -Duse_system_libpng=1 \
101 -Duse_system_opencv=1 \
102 -Duse_system_zlib=1 \
b2f50394
ER
103 -Dsystem_include_path_apr=%{_includedir}/apr \
104 -Dsystem_include_path_aprutil=%{_includedir}/apr-util \
105 -Dsystem_include_path_httpd=%{_includedir}/apache \
42a31ab3
ER
106 %{nil}
107
1a9213c5 108%{__make} mod_pagespeed js_minify css_minify_main \
08710a2f
ER
109 BUILDTYPE=%{!?debug:Release}%{?debug:Debug} \
110 %{?with_verbose:V=1} \
111 CC="%{__cc}" \
112 CXX="%{__cxx}" \
113 CC.host="%{__cc}" \
114 CXX.host="%{__cxx}" \
115 LINK.host="%{__cxx}" \
116 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
117 CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
5bdfa704 118 %{nil}
08710a2f
ER
119
120%install
121rm -rf $RPM_BUILD_ROOT
1a9213c5
ER
122install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir},%{_bindir},%{cachedir}}
123
5bdfa704 124%{__make} -j1 -C install staging_except_module \
06daee42 125 APACHE_ROOT=%{_pkgrootdir} \
3f27b998 126 APACHE_MODULES=modules \
06daee42 127 APACHE_DOC_ROOT=%{htdocsdir} \
5bdfa704
ER
128 MOD_PAGESPEED_CACHE=%{cachedir} \
129 MOD_PAGESPEED_STATS_LOG=/var/log/httpd/mod_pagespeed_stats.log \
06daee42
ER
130 STAGING_DIR=staging
131
1a9213c5
ER
132out=out/%{!?debug:Release}%{?debug:Debug}
133install -p $out/libmod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
134install -p $out/js_minify $RPM_BUILD_ROOT%{_bindir}/pagespeed_js_minify
135install -p $out/css_minify_main $RPM_BUILD_ROOT%{_bindir}/pagespeed_css_minify
136
5bdfa704 137cd install/staging
06daee42
ER
138cat > $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf <<EOF
139LoadModule %{mod_name}_module modules/mod_%{mod_name}.so
140
141$(cat pagespeed.conf)
142EOF
08710a2f 143
1a9213c5
ER
144cp -p pagespeed_libraries.conf $RPM_BUILD_ROOT%{_sysconfdir}/91_mod_%{mod_name}_libraries.conf
145
3f27b998
ER
146install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
147cp -a mod_pagespeed_example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
148
08710a2f
ER
149%clean
150rm -rf $RPM_BUILD_ROOT
151
152%post
153%service -q httpd restart
154
155%postun
156if [ "$1" = "0" ]; then
157 %service -q httpd restart
158fi
159
160%files
161%defattr(644,root,root,755)
08710a2f 162%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
1a9213c5
ER
163%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}_libraries.conf
164%attr(755,root,root) %{_bindir}/pagespeed_css_minify
165%attr(755,root,root) %{_bindir}/pagespeed_js_minify
b6a5d8d0 166%attr(755,root,root) %{_pkglibdir}/mod_%{mod_name}.so
3f27b998 167%{_examplesdir}/%{name}-%{version}
5bdfa704 168%dir %attr(770,root,http) %{cachedir}
This page took 0.124443 seconds and 4 git commands to generate.