]> git.pld-linux.org Git - packages/apache-mod_ntlm.git/blob - apache-mod_ntlm.spec
- removed all Group fields translations (oure rpm now can handle translating
[packages/apache-mod_ntlm.git] / apache-mod_ntlm.spec
1 %define         mod_name        ntlm
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the NTLM authentication module for Apache
4 Summary(pl):    Modu³ autentykacji NTLM dla Apache
5 Name:           apache-mod_%{mod_name}
6 Version:        0.3
7 Release:        2
8 License:        GPL
9 Group:          Networking/Daemons
10 Source0:        http://prdownloads.sourceforge.net/modntlm/mod_%{mod_name}-%{version}.tar.gz
11 Patch0:         %{name}-symbol_fix.patch
12 BuildRequires:  %{apxs}
13 BuildRequires:  apache(EAPI)-devel
14 Prereq:         %{_sbindir}/apxs
15 Requires:       apache(EAPI)
16 URL:            http://modntlm.sourceforge.net/
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
20
21 %description
22 This is an authentication module for Apache that allows you to
23 authenticate HTTP clients using samba or windows-like server (using
24 NTLM protocol).
25
26 %description -l pl
27 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
28 klientów HTTP poprzez sambê lub serwer na Windows (z u¿yciem protoko³u
29 NTLM).
30
31 %prep 
32 %setup -q -n mod_%{mod_name}-%{version}
33 %patch -p0
34
35 %build
36 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.so
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT%{_pkglibdir}
41
42 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
43
44 %post
45 %{_sbindir}/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
46 if [ -f /var/lock/subsys/httpd ]; then
47         /etc/rc.d/init.d/httpd restart 1>&2
48 fi
49
50 %preun
51 if [ "$1" = "0" ]; then
52         %{_sbindir}/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
53         if [ -f /var/lock/subsys/httpd ]; then
54                 /etc/rc.d/init.d/httpd restart 1>&2
55         fi
56 fi
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.050929 seconds and 3 git commands to generate.