]> git.pld-linux.org Git - packages/apache-mod_ntlm.git/blob - apache-mod_ntlm.spec
- massive attack: adding Source-md5
[packages/apache-mod_ntlm.git] / apache-mod_ntlm.spec
1 %define         mod_name        ntlm
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the NTLM authentication module for Apache
4 Summary(pl):    Modu³ autentykacji NTLM dla Apache
5 Name:           apache-mod_%{mod_name}
6 Version:        0.3
7 Release:        3
8 License:        GPL
9 Group:          Networking/Daemons
10 Source0:        http://dl.sourceforge.net/modntlm/mod_%{mod_name}-%{version}.tar.gz
11 # Source0-md5:  fff67ce0ddb524588ea01cb4a015890c
12 URL:            http://modntlm.sourceforge.net/
13 BuildRequires:  %{apxs}
14 BuildRequires:  apache(EAPI)-devel
15 Requires(post,preun):   %{apxs}
16 Requires:       apache(EAPI)
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
20
21 %description
22 This is an authentication module for Apache that allows you to
23 authenticate HTTP clients using samba or windows-like server (using
24 NTLM protocol).
25
26 %description -l pl
27 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
28 klientów HTTP poprzez sambê lub serwer na Windows (z u¿yciem protoko³u
29 NTLM).
30
31 %prep
32 %setup -q -n mod_%{mod_name}-%{version}
33
34 %build
35 PATH=$PATH:/usr/sbin %{__make}
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT%{_pkglibdir}
40
41 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %post
47 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
48 if [ -f /var/lock/subsys/httpd ]; then
49         /etc/rc.d/init.d/httpd restart 1>&2
50 fi
51
52 %preun
53 if [ "$1" = "0" ]; then
54         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
55         if [ -f /var/lock/subsys/httpd ]; then
56                 /etc/rc.d/init.d/httpd restart 1>&2
57         fi
58 fi
59
60 %files
61 %defattr(644,root,root,755)
62 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.057695 seconds and 3 git commands to generate.