]> git.pld-linux.org Git - packages/apache-mod_nss.git/blob - apache-mod_nss.spec
a310c0ed918c23b06cf78946e70ceccbbadab0be
[packages/apache-mod_nss.git] / apache-mod_nss.spec
1 # TODO
2 # - certutil tries to open /dev/tty to get passphrase for nss db init
3 %define         mod_name        nss
4 %define         apxs            /usr/sbin/apxs
5 Summary:        mod_nss - strong cryptography support for Apache using SSL/TLS library NSS
6 Summary(pl.UTF-8):      mod_nss - silna kryptografia dla Apache'a przy użyciu biblioteki SSL/TLS NSS
7 Name:           apache-mod_nss
8 Version:        1.0.7
9 Release:        0.4
10 License:        Apache v2.0
11 Group:          Networking/Daemons
12 Source0:        http://directory.fedoraproject.org/sources/mod_nss-%{version}.tar.gz
13 # Source0-md5:  71107cbc702bf07c6c79843aa92a0e09
14 Source1:        apache-server.crt
15 Source2:        apache-server.key
16 Patch0:         %{name}-config.patch
17 URL:            http://directory.fedoraproject.org/wiki/Mod_nss
18 BuildRequires:  %{apxs}
19 BuildRequires:  apache-devel >= 2.0
20 BuildRequires:  apr-devel >= 1:1.0
21 BuildRequires:  apr-util-devel >= 1:1.0
22 BuildRequires:  nspr-devel >= 1:4.6.2
23 BuildRequires:  nss-devel >= 1:3.11.3
24 BuildRequires:  nss-tools
25 BuildRequires:  openssl-tools
26 Requires:       apache(modules-api) = %{apache_modules_api}
27 Requires:       nspr >= 1:4.6.2
28 Requires:       nss >= 1:3.11.3
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
32 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
33
34 %description
35 An Apache 2.x module for implementing crypto using the Mozilla NSS
36 crypto libraries. This supports SSL v3/TLS v1 including support for
37 client certificate authentication. NSS provides web applications with
38 a FIPS 140 certified crypto provider and support for a full range of
39 PKCS#11 devices.
40
41 mod_nss is based directly on the mod_ssl package from Apache 2.0.54.
42 It is a conversion from using OpenSSL calls to using NSS calls
43 instead.
44
45 %description -l pl.UTF-8
46 Moduł Apache'a 2.x implementujący kryptografię przy użyciu bibliotek
47 kryptograficznych Mozilla NSS. Obsługuje SSL v3/TLS v1 wraz z
48 uwierzytelnianiem z użyciem certyfikatu klienta. NSS zapewnia
49 aplikacjom WWW dostarczanie kryptografii z certyfikacją FIPS 140 i
50 obsługę pełnego zakresu urządzeń PKCS#11.
51
52 mod_nss jest oparty bezpośrednio na pakiecie mod_ssl z Apache'a
53 2.0.54, jedynie został zmodyfikowany tak, aby używał wywołań NSS
54 zamiast OpenSSL.
55
56 %prep
57 %setup -q -n mod_nss-%{version}
58 %patch0 -p1
59 cp %{SOURCE1} server.crt
60 cp %{SOURCE2} server.key
61
62 %build
63 # apr-util is missing in configure check
64 CPPFLAGS="`apu-1-config --includes`"
65 %configure \
66         --with-apxs=%{apxs} \
67         --with-apr-config \
68         --with-nspr-inc=/usr/include/nspr \
69         --with-nspr-lib=%{_libdir} \
70         --with-nss-inc=/usr/include/nss \
71         --with-nss-lib=%{_libdir}
72
73 %{__make}
74
75 install -d nss
76 # XXX: this is interactive
77 certutil -N -d nss
78
79 openssl pkcs12 -export -in server.crt -inkey server.key -out server.p12 -name "Server-Cert" -passout pass:
80 pk12util -i server.p12 -d nss -W ''
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_pkglibdir},%{_sysconfdir}/{conf.d,nss}}
85 install .libs/libmodnss.so $RPM_BUILD_ROOT%{_pkglibdir}
86 install nss_pcache $RPM_BUILD_ROOT%{_sbindir}
87
88 cp -a nss.conf $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/40_mod_%{mod_name}.conf
89 cp -a nss/* $RPM_BUILD_ROOT%{_sysconfdir}/nss
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post
95 %service -q httpd restart
96
97 %postun
98 if [ "$1" = "0" ]; then
99         %service -q httpd restart
100 fi
101
102 %files
103 %defattr(644,root,root,755)
104 %doc NOTICE README TODO docs/mod_nss.html migrate.pl
105 %attr(750,root,root) %dir %{_sysconfdir}/nss
106 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nss/cert8.db
107 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nss/key3.db
108 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nss/secmod.db
109 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
110 %attr(755,root,root) %{_pkglibdir}/libmodnss.so
111 %attr(755,root,root) %{_sbindir}/nss_pcache
This page took 0.05971 seconds and 2 git commands to generate.