]> git.pld-linux.org Git - packages/apache-mod_nss.git/blob - apache-mod_nss.spec
- assume it will work with apache 2.x
[packages/apache-mod_nss.git] / apache-mod_nss.spec
1 # TODO
2 # - apache config
3 %define         apxs            /usr/sbin/apxs
4 Summary:        mod_nss - strong cryptography support for Apache using SSL/TLS library NSS
5 Summary(pl.UTF-8):      mod_nss - silna kryptografia dla Apache'a przy użyciu biblioteki SSL/TLS NSS
6 Name:           apache-mod_nss
7 Version:        1.0.7
8 Release:        0.1
9 License:        Apache v2.0
10 Group:          Networking/Daemons
11 Source0:        http://directory.fedoraproject.org/sources/mod_nss-%{version}.tar.gz
12 # Source0-md5:  71107cbc702bf07c6c79843aa92a0e09
13 URL:            http://directory.fedoraproject.org/wiki/Mod_nss
14 BuildRequires:  %{apxs}
15 BuildRequires:  apache-devel >= 2.0
16 BuildRequires:  apr-devel >= 1:1.0
17 BuildRequires:  apr-util-devel >= 1:1.0
18 BuildRequires:  nspr-devel >= 1:4.6.2
19 BuildRequires:  nss-devel >= 1:3.11.3
20 Requires:       apache(modules-api) = %{apache_modules_api}
21 Requires:       nspr >= 1:4.6.2
22 Requires:       nss >= 1:3.11.3
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
26 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
27
28 %description
29 An Apache 2.x module for implementing crypto using the Mozilla NSS
30 crypto libraries. This supports SSL v3/TLS v1 including support for
31 client certificate authentication. NSS provides web applications with
32 a FIPS 140 certified crypto provider and support for a full range of
33 PKCS#11 devices.
34
35 mod_nss is based directly on the mod_ssl package from Apache 2.0.54.
36 It is a conversion from using OpenSSL calls to using NSS calls
37 instead.
38
39 %description -l pl.UTF-8
40 Moduł Apache'a 2.x implementujący kryptografię przy użyciu bibliotek
41 kryptograficznych Mozilla NSS. Obsługuje SSL v3/TLS v1 wraz z
42 uwierzytelnianiem z użyciem certyfikatu klienta. NSS zapewnia
43 aplikacjom WWW dostarczanie kryptografii z certyfikacją FIPS 140 i
44 obsługę pełnego zakresu urządzeń PKCS#11.
45
46 mod_nss jest oparty bezpośrednio na pakiecie mod_ssl z Apache'a
47 2.0.54, jedynie został zmodyfikowany tak, aby używał wywołań NSS
48 zamiast OpenSSL.
49
50 %prep
51 %setup -q -n mod_nss-%{version}
52
53 %build
54 # apr-util is missing in configure check
55 CPPFLAGS="`apu-1-config --includes`"
56 %configure \
57         --with-apxs=%{apxs} \
58         --with-apr-config \
59         --with-nspr-inc=/usr/include/nspr \
60         --with-nspr-lib=%{_libdir} \
61         --with-nss-inc=/usr/include/nss \
62         --with-nss-lib=%{_libdir}
63
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_pkglibdir}}
69
70 install .libs/libmodnss.so $RPM_BUILD_ROOT%{_pkglibdir}
71 install nss_pcache $RPM_BUILD_ROOT%{_sbindir}
72
73 # TODO: nss.conf -> %{_sysconfdir}/httpd.conf/XX_mod_nss.conf
74 # (NOTE: at least default config conflicts with mod_ssl)
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc NOTICE README TODO docs/mod_nss.html nss.conf
82 %attr(755,root,root) %{_pkglibdir}/libmodnss.so
83 %attr(755,root,root) %{_sbindir}/nss_pcache
This page took 0.035668 seconds and 3 git commands to generate.