]> git.pld-linux.org Git - packages/apache-mod_mono.git/blob - apache-mod_mono.spec
- up to 1.0.1
[packages/apache-mod_mono.git] / apache-mod_mono.spec
1
2 # TODO : figure out how to kill mod-mono-server.exe process 
3 #        when apache is restarted
4
5 %define         mod_name mod_mono
6 Summary:        Mono module for Apache 2
7 Summary(pl):    Modu³ Mono dla serwera Apache 2
8 Name:           apache-mod_mono
9 Version:        1.0.1
10 Release:        0.9
11 Epoch:          1
12 License:        Apache
13 Group:          Networking/Daemons
14 Source0:        http://mono2.ximian.com/archive/%{version}/%{mod_name}-%{version}.tar.gz
15 # Source0-md5:  5adb398b270865c484cea53b79e3def4
16 Patch0:         %{name}-apu-config.patch
17 URL:            http://www.mono-project.com/
18 BuildRequires:  apache-devel >= 2.0
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  libtool
22 BuildRequires:  mono-csharp >= 1.0
23 Requires:       xsp
24 Requires:       apache >= 2.0
25 Requires:       mono-csharp >= 1.0
26 Obsoletes:      mod_mono
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         apxs            %{_sbindir}/apxs
30 %define         _httpdir        /home/services/httpd
31 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
32
33 %description
34 This is an experimental module that allows you to run ASP.NET pages on
35 Unix with Apache and Mono.
36
37 %description -l pl
38 Ten eksperymentalny modu³ umo¿liwia uruchamianie stron ASP.NET na
39 Uniksie z serwerem Apache i Mono.
40
41 %package -n dotnet-xsp
42 Summary:        Mono ASP.NET Standalone Web Server
43 Summary(pl):    Server HTTP obs³uguj±cy ASP.NET
44 Group:          Networking/Daemons
45 Requires:       %{name} = %{epoch}:%{version}-%{release}
46 Requires:       mono-csharp >= 1.0
47
48 %description -n dotnet-xsp
49 Provides a minimalistic web server which hosts the ASP.NET runtime and 
50 can be used to test and debug web applications that use the System.Web
51 facilities in  Mono.
52
53 %prep
54 %setup -q -n %{mod_name}-%{version}
55 %patch0 -p1
56
57 %build
58 rm -rf $RPM_BUILD_ROOT
59 # Build Apache Module
60 %{__libtoolize}
61 %{__aclocal}
62 %{__autoconf}
63 %{__automake}
64
65 %configure \
66         --with-apxs=%{apxs} \
67         --with-apr-config=%{_bindir}/apr-config \
68         --with-apu-config=%{_bindir}/apu-config
69         
70 %{__make} \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 # Build Mono DLL
74 %{__make} -C src -f makedll.mak
75
76 %install
77 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/httpd/httpd.conf,%{_pkglibdir},%{_mandir}/man8}
78
79 install src/.libs/libmod_mono.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_mono.so
80 install src/ModMono.dll $RPM_BUILD_ROOT%{_libdir}
81 install man/mod_mono.8 $RPM_BUILD_ROOT%{_mandir}/man8
82
83 cat > $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf/70_mod_mono.conf <<EOF
84 LoadModule mono_module modules/mod_mono.so
85 MonoApplications "/asp_net:%{_httpdir}/asp_net"
86 Alias /asp_net "%{_httpdir}/asp_net"
87 <Location /asp_net>
88     SetHandler mono
89 </Location>
90 EOF
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %defattr(644,root,root,755)
97 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/httpd.conf/*
98 %doc ChangeLog INSTALL NEWS README
99 %attr(755,root,root) %{_pkglibdir}/mod_mono.so
100 %attr(755,root,root) %{_libdir}/ModMono.dll
101 %{_mandir}/man8/*
This page took 0.064016 seconds and 3 git commands to generate.