]> git.pld-linux.org Git - packages/apache-mod_mono.git/blob - apache-mod_mono.spec
- dropped SourceX-size
[packages/apache-mod_mono.git] / apache-mod_mono.spec
1 #
2 # TODO:
3 # - figure out how to kill mod-mono-server.exe process
4 #   when apache is restarted
5 #
6 %define         _name           mod_mono
7 %define         apxs            /usr/sbin/apxs
8 Summary:        Mono module for Apache 2
9 Summary(pl):    Modu³ Mono dla serwera Apache 2
10 Name:           apache-%{_name}
11 Version:        1.0.6
12 Release:        1
13 Epoch:          1
14 License:        Apache
15 Group:          Networking/Daemons
16 Source0:        http://mono2.ximian.com/archive/%{version}/%{_name}-%{version}.tar.gz
17 # Source0-md5:  411a6608a14ac56557804d2b01923b92
18 Patch0:         %{name}-apu-config.patch
19 Patch1:         %{name}-apr_fixes.patch
20 URL:            http://www.mono-project.com/
21 BuildRequires:  apache-devel >= 2.0.52-2
22 BuildRequires:  %{apxs}
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  libtool
26 BuildRequires:  mono-csharp >= 1.0
27 Requires:       xsp
28 Requires:       apache >= 2.0.52-2
29 Requires:       mono-csharp >= 1.0
30 Obsoletes:      mod_mono
31 ExcludeArch:    alpha
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _httpdir        /home/services/httpd
35 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
36 %define     _sysconfdir /etc/httpd
37
38 %description
39 This is an experimental module that allows you to run ASP.NET pages on
40 Unix with Apache and Mono.
41
42 %description -l pl
43 Ten eksperymentalny modu³ umo¿liwia uruchamianie stron ASP.NET na
44 Uniksie z serwerem Apache i Mono.
45
46 %prep
47 %setup -q -n %{_name}-%{version}
48 %patch0 -p1
49 %patch1 -p1
50
51 %build
52 rm -rf $RPM_BUILD_ROOT
53 # Build Apache Module
54 %{__libtoolize}
55 %{__aclocal}
56 %{__autoconf}
57 %{__automake}
58
59 %configure \
60         --with-apxs=%{apxs} \
61         --with-apr-config=%{_bindir}/apr-1-config \
62         --with-apu-config=%{_bindir}/apu-1-config \
63         CFLAGS="%{rpmcflags} -D_GNU_SOURCE -D_LARGEFILE64_SOURCE"
64
65 %{__make} \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/httpd.conf,%{_pkglibdir},%{_mandir}/man8}
71
72 install src/.libs/%{_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/%{_name}.so
73 install man/%{_name}.8 $RPM_BUILD_ROOT%{_mandir}/man8
74
75 cat > $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/70_%{_name}.conf <<EOF
76 LoadModule mono_module modules/%{_name}.so
77 MonoApplications "/asp_net:%{_httpdir}/asp_net"
78 Alias /asp_net "%{_httpdir}/asp_net"
79 <Location /asp_net>
80         SetHandler mono
81 </Location>
82 EOF
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd.conf/*
90 %doc ChangeLog INSTALL NEWS README
91 %attr(755,root,root) %{_pkglibdir}/%{_name}.so
92 %{_mandir}/man8/*
This page took 0.076473 seconds and 3 git commands to generate.