]> git.pld-linux.org Git - packages/apache-mod_macro.git/blob - apache-mod_macro.spec
- new
[packages/apache-mod_macro.git] / apache-mod_macro.spec
1 %define         mod_name        macro
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Apache module to allow macros in apache config files
4 Summary(pl):    Modu³ do apache pozwalaj±cy u¿ywaæ makr w konfiguracji
5 Name:           apache-mod_%{mod_name}
6 Version:        1.1.6
7 Release:        0.1
8 License:        Apache
9 Group:          Networking/Daemons
10 Source0:        http://www.cri.ensmp.fr/~coelho/mod_macro/mod_%{mod_name}-%{version}.tar.bz2
11 # Source0-md5:  c79c299f650b35292d3b71da19e42e45
12 URL:            http://www.cri.ensmp.fr/~coelho/mod_macro/
13 BuildRequires:  apache-devel
14 Requires(post,preun):   %{apxs}
15 Requires:       apache
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
19 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR)
20
21 %description
22 Apache module to allow macros in apache config files.
23
24 %description -l pl
25 Modu³ do apache pozwalaj±cy u¿ywaæ makr w plikach konfiguracyjnych.
26
27 %prep
28 %setup -q -n mod_%{mod_name}-%{version}
29
30 %build
31 %{apxs} -c mod_%{mod_name}.c
32
33 %install
34 rm -rf $RPM_BUILD_ROOT
35 install -d $RPM_BUILD_ROOT%{_pkglibdir}
36
37 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %post
43 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
44 if [ -f /var/lock/subsys/httpd ]; then
45         /etc/rc.d/init.d/httpd restart 1>&2
46 fi
47
48 %preun
49 if [ "$1" = "0" ]; then
50         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
51         if [ -f /var/lock/subsys/httpd ]; then
52                 /etc/rc.d/init.d/httpd restart 1>&2
53         fi
54 fi
55
56 %files
57 %defattr(644,root,root,755)
58 %doc README CHANGES
59 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.058536 seconds and 4 git commands to generate.