]> git.pld-linux.org Git - packages/apache-mod_log_sql.git/blob - apache-mod_log_sql.spec
- regenerated autocrap
[packages/apache-mod_log_sql.git] / apache-mod_log_sql.spec
1 # todo: split *.so to subpackages: mysql/dbi/ssl
2 %define         mod_name        log_sql
3 %define         apxs            /usr/sbin/apxs
4 Summary:        SQL logging module for Apache
5 Summary(pl):    Modu³ logowania zapytañ do Apache do bazy SQL
6 Name:           apache-mod_%{mod_name}
7 # NOTE: remember about apache1-mod_log_sql when updating!
8 Version:        1.99
9 Release:        2
10 License:        Apache (?)
11 Group:          Networking/Daemons
12 Source0:        http://www.outoforder.cc/downloads/mod_log_sql/mod_%{mod_name}-%{version}.tar.gz
13 # Source0-md5:  e246a3d8e96d2d62715eb34f75c7c11d
14 URL:            http://www.outoforder.cc/projects/apache/mod_log_sql/
15 BuildRequires:  %{apxs}
16 BuildRequires:  apache-devel >= 2.0.40
17 BuildRequires:  libdbi-devel >= 0.7.0
18 BuildRequires:  mysql-devel >= 3.23.30
19 Requires(post,preun):   %{apxs}
20 Requires(post,preun):   grep
21 Requires(preun):        fileutils
22 Requires:       apache
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _sysconfdir     /etc/httpd
26 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
27
28 %description
29 mod_log_sql is a logging module for Apache 1.3 and 2.0 which logs all requests
30 to a database.
31
32 %description -l pl
33 mod_log_sql jest modu³em loguj±cym dla Apache 1.3 i 2.0, który pozwala na
34 logowanie wszystkich zapytañ do bazy danych.
35
36 %prep
37 %setup -q -n mod_%{mod_name}-%{version}
38
39 %build
40 %{__libtoolize}
41 %{__aclocal}
42 %{__autoconf}
43 %configure \
44         --with-apxs=%{apxs}
45 %{__make}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pkglibdir}}
50
51 install .libs/*.so $RPM_BUILD_ROOT%{_pkglibdir}
52 #install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
53
54 rm docs/Makefile* docs/*.xml contrib/Makefile*
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 %{apxs} -e -a -n %{mod_name} %{_libexecdir}/mod_%{mod_name}.so 1>&2
61 if [ -f /var/lock/subsys/apache ]; then
62         /etc/rc.d/init.d/apache restart 1>&2
63 fi
64
65 %postun
66 if [ "$1" = "0" ]; then
67         %{apxs} -e -A -n %{mod_name} %{_libexecdir}/mod_%{mod_name}.so 1>&2
68         if [ -f /var/lock/subsys/apache ]; then
69                 /etc/rc.d/init.d/apache restart 1>&2
70         fi
71 fi
72
73 %files
74 %defattr(644,root,root,755)
75 %doc AUTHORS CHANGELOG TODO contrib docs LICENSE
76 %attr(755,root,root) %{_pkglibdir}/*
77 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.conf
This page took 0.082955 seconds and 4 git commands to generate.