]> git.pld-linux.org Git - packages/apache-mod_gnutls.git/blob - apache-mod_gnutls.spec
b585796f5c32ce762647135a04351662e69e9de3
[packages/apache-mod_gnutls.git] / apache-mod_gnutls.spec
1 %define         mod_name        gnutls
2 %define         apxs            /usr/sbin/apxs
3 Summary:        SSL v3, TLS 1.0 and TLS 1.1 encryption for Apache HTTPD
4 Summary(pl.UTF-8):      Szyfrowanie SSL v3, TLS 1.0 i TLS 1.1 dla serwera HTTP Apache
5 Name:           apache-mod_%{mod_name}
6 Version:        0.5.4
7 Release:        0.1
8 License:        Apache Group License
9 Group:          Networking/Daemons/HTTP
10 Source0:        http://www.outoforder.cc/downloads/mod_gnutls/mod_gnutls-%{version}.tar.bz2
11 # Source0-md5:  4be7daab0e4b0af9b2eff104fc61af87
12 Source1:        %{name}.conf
13 Source2:        %{name}-dhfile
14 Source3:        %{name}-rsafile
15 Patch0:         %{name}-libtool.patch
16 Patch1:         %{name}-paths.patch
17 URL:            http://www.outoforder.cc/projects/apache/mod_gnutls/
18 BuildRequires:  %{apxs}
19 BuildRequires:  apache-devel >= 2.0.42
20 BuildRequires:  apr_memcache-devel >= 0.7.0
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  gnutls-devel >= 2.4.0
24 BuildRequires:  libtool
25 BuildRequires:  pkgconfig
26 Requires:       apache(modules-api) = %apache_modules_api
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
30 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
31
32 %description
33 mod_gnutls uses the GnuTLS library to provide SSL v3, TLS 1.0 and TLS
34 1.1 encryption for Apache HTTPD. It is similar to mod_ssl in purpose,
35 but does not use OpenSSL.
36
37 Features:
38  - Support for SSL v3, TLS 1.0 and TLS 1.1.
39  - Support for Server Name Indication
40  - Distributed SSL Session Cache via Memcached
41  - Local SSL Session Cache using DBM
42
43 %description -l pl.UTF-8
44 mod_gnutls używa biblioteki GnuTLS do obsługi szyfrowania SSL v3, TLS
45 1.0 i TLS 1.1 dla serwera HTTP Apache. Pod względem przeznaczenia jest
46 podobny do mod_ssl, ale nie używa biblioteki OpenSSL.
47
48 Możliwości:
49  - obsługa SSL v3, TLS 1.0 i TLS 1.1
50  - obsługa identyfikacji nazwy serwera (Server Name Indication)
51  - rozproszona pamięć podręczna sesji SSL poprzez Memcached
52  - lokalna pamięć podręczna sesji SSL korzystająca z DBM
53
54 %prep
55 %setup -q -n mod_%{mod_name}-%{version}
56 %patch0 -p1
57 %patch1 -p1
58
59 %build
60 cd apache2
61 %{__libtoolize}
62 %{__aclocal} -I m4
63 %{__autoheader}
64 %{__automake}
65 %{__autoconf}
66 %configure \
67         --with-apxs=%{apxs} 
68
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/{conf.d,tls}}
74 install src/.libs/libmod_gnutls.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_gnutls.so
75 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/40_mod_gnutls.conf
76 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/tls/dhfile
77 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/tls/rsafile
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post
83 if [ "$1" = "1" ]; then
84         echo "Generating dhfile/rsafile - this may take some time..."
85         d=/etc/httpd/tls
86         [ -f "$d/dhfile" ] || /usr/bin/certtool --generate-dh-params --bits 1024 --outfile $d/dhfile
87         [ -f "$d/rsafile" ] || /usr/bin/certtool --generate-privkey --bits 512 --outfile $d/rsafile
88 fi
89 %service -q httpd restart
90
91 %postun
92 if [ "$1" = "0" ]; then
93         %service -q httpd restart
94         rm -f /etc/httpd/tls/{dhfile,rsafile}
95 fi
96
97 %files
98 %defattr(644,root,root,755)
99 %attr(750,root,root) %dir %{_sysconfdir}/tls
100 %dir %{_sysconfdir}/tls
101 %attr(640,root,root) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_gnutls.conf
102 %attr(755,root,root) %{_pkglibdir}/mod_gnutls.so
This page took 0.225923 seconds and 3 git commands to generate.