]> git.pld-linux.org Git - packages/apache-mod_fcgid.git/blob - apache-mod_fcgid.spec
- HTTP group
[packages/apache-mod_fcgid.git] / apache-mod_fcgid.spec
1 %define         mod_name        fcgid
2 %define         apxs            /usr/sbin/apxs
3 Summary:        A binary compatibility alternative to Apache module mod_fastcgi
4 Summary(pl.UTF-8):      Binarnie kompatybilna alternatywa dla modułu Apache'a mod_fastcgi
5 Name:           apache-mod_%{mod_name}
6 Version:        1.03
7 Release:        3
8 License:        GPL v2
9 Group:          Networking/Daemons/HTTP
10 Source0:        http://fastcgi.coremail.cn/mod_%{mod_name}.%{version}.tar.gz
11 # Source0-md5:  dbcd5c96f8d6c6fcb7471abf527d176f
12 Source1:        %{name}.conf
13 Patch0:         %{name}-apr-status-is-success.patch
14 Patch1:         %{name}-apache.patch
15 URL:            http://fastcgi.coremail.cn/
16 BuildRequires:  %{apxs}
17 BuildRequires:  apache-devel >= 2.0.52-2
18 BuildRequires:  libtool
19 BuildRequires:  rpmbuild(macros) >= 1.268
20 Requires:       apache(modules-api) = %apache_modules_api
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
24 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
25
26 %description
27 A binary compatibility alternative to Apache module mod_fastcgi.
28 mod_fcgid has a new process management strategy, which concentrates on
29 reducing the number of fastcgi server, and kick out the corrupt
30 fastcgi server as soon as possible.
31
32 %description -l pl.UTF-8
33 Binarnie kompatybilna alternatywa dla modułu Apache'a mod_fastcgi.
34 mod_fcgid to nowa strategia zarządzania procesami, koncentrująca się
35 na redukcji liczby serwerów fastcgi i usuwaniu uszkodzonych serwerów
36 fastcgi najszybciej jak to możliwe.
37
38 %prep
39 %setup -q -n mod_%{mod_name}.%{version}
40 %patch0 -p1
41 %patch1 -p1
42
43 %build
44 %{__make} \
45         top_dir=%{_pkglibdir} \
46         APXS=%{apxs} \
47         INCLUDES="-I%(%{apxs} -q INCLUDEDIR)"
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
52
53 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
54 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/70_mod_%{mod_name}.conf
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 %service -q httpd restart
61
62 %postun
63 if [ "$1" = "0" ]; then
64         %service -q httpd restart
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 %doc AUTHOR ChangeLog
70 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
71 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.154804 seconds and 3 git commands to generate.