]> git.pld-linux.org Git - packages/apache-mod_fcgid.git/blob - apache-mod_fcgid.spec
- pl
[packages/apache-mod_fcgid.git] / apache-mod_fcgid.spec
1 %define         apxs    /usr/sbin/apxs
2 %define         _apache1        %(rpm -q apache-devel 2> /dev/null | grep -Eq '\\-2\\.[0-9]+\\.' && echo 0 || echo 1)
3 Summary:        A binary compatibility alternative to Apache module mod_fastcgi
4 Summary(pl):    Binarnie kompatybilna alternatywa dla modu³u Apache'a mod_fastcgi
5 Name:           apache-mod_fcgid
6 Version:        0.7
7 Release:        1
8 License:        distributable
9 Group:          Networking/Daemons
10 Source0:        http://fastcgi.coremail.cn/mod_fcgid.%{version}.tar.gz
11 # Source0-md5:  1bfdf0274caf9ecaee089e4b3f70326e
12 Source1:        70_mod_fastcgi.conf
13 URL:            http://fastcgi.coremail.cn/
14 BuildRequires:  %{apxs}
15 BuildRequires:  apache-devel
16 BuildRequires:  libtool
17 BuildRequires:  sed >= 4.0
18 Requires(post,preun):   %{apxs}
19 Requires:       apache >= 1.3.1
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _libexecdir     %{_libdir}/apache
23
24 %description
25 A binary compatibility alternative to Apache module mod_fastcgi.
26 mod_fcgid has a new process management strategy, which concentrates on
27 reducing the number of fastcgi server, and kick out the corrupt
28 fastcgi server as soon as possible.
29
30 %description -l pl
31 Binarnie kompatybilna alternatywa dla modu³u Apache'a mod_fastcgi.
32 mod_fcgid to nowa strategia zarz±dzania procesami, koncentruj±ca siê
33 na redukcji liczby serwerów fastcgi i usuwaniu uszkodzonych serwerów
34 fastcgi najszybciej jak to mo¿liwe.
35
36 %prep
37 %setup -q -n mod_fcgid
38
39 %build
40 sed -i -e 's#top_dir.*=.*#top_dir = %{_libexecdir}#g' Makefile
41 echo "INCLUDES=`apr-config --includes` `apu-config --includes` -I%{_includedir}/apache" >> Makefile
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
47 install -d $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf
48
49 libtool --mode=install install mod_fcgid.la $RPM_BUILD_ROOT%{_libexecdir}
50 install %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/httpd.conf/70_mod_fcgid.conf
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 if [ -f /var/lock/subsys/httpd ]; then
57         /etc/rc.d/init.d/httpd restart 1>&2
58 else
59         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
60 fi
61
62 %preun
63 if [ "$1" = "0" ]; then
64         if [ -f /var/lock/subsys/httpd ]; then
65                 /etc/rc.d/init.d/httpd restart 1>&2
66         fi
67 fi
68
69 %files
70 %defattr(644,root,root,755)
71 %doc AUTHOR ChangeLog
72 %attr(755,root,root) %{_libexecdir}/*.so
This page took 0.082822 seconds and 3 git commands to generate.