]> git.pld-linux.org Git - packages/apache-mod_fcgid.git/blob - apache-mod_fcgid.spec
361d5f5bd91b4bb2c48a5a7c5ad8f78417bf7d2f
[packages/apache-mod_fcgid.git] / apache-mod_fcgid.spec
1 %define         mod_name        fcgid
2 %define         apxs            /usr/sbin/apxs
3 Summary:        A binary compatibility alternative to Apache module mod_fastcgi
4 Summary(pl):    Binarnie kompatybilna alternatywa dla modu³u Apache'a mod_fastcgi
5 Name:           apache-mod_%{mod_name}
6 Version:        1.01
7 Release:        2
8 License:        GPL v2
9 Group:          Networking/Daemons
10 Source0:        http://fastcgi.coremail.cn/mod_%{mod_name}.%{version}.tar.gz
11 # Source0-md5:  2cedb4c88ecf2c6754b237d27297aa1d
12 Source1:        %{name}.conf
13 URL:            http://fastcgi.coremail.cn/
14 BuildRequires:  %{apxs}
15 BuildRequires:  apache-devel >= 2
16 BuildRequires:  libtool
17 BuildRequires:  sed >= 4.0
18 Requires(post,preun):   %{apxs}
19 Requires:       apache >= 2
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR)
23 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
24
25 %description
26 A binary compatibility alternative to Apache module mod_fastcgi.
27 mod_fcgid has a new process management strategy, which concentrates
28 on reducing the number of fastcgi server, and kick out the corrupt
29 fastcgi server as soon as possible.
30
31 %description -l pl
32 Binarnie kompatybilna alternatywa dla modu³u Apache'a mod_fastcgi.
33 mod_fcgid to nowa strategia zarz±dzania procesami, koncentruj±ca siê
34 na redukcji liczby serwerów fastcgi i usuwaniu uszkodzonych serwerów
35 fastcgi najszybciej jak to mo¿liwe.
36
37 %prep
38 %setup -q -n mod_%{mod_name}.%{version}
39
40 %build
41 %{__make} \
42         top_dir=%{_pkglibdir} \
43         APXS=%{_apxs} \
44         INCLUDES="-I%(%{apxs} -q INCLUDEDIR)"
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
49
50 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
51 install %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/httpd.conf/70_mod_%{mod_name}.conf
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 if [ -f /var/lock/subsys/httpd ]; then
58         /etc/rc.d/init.d/httpd restart 1>&2
59 else
60         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
61 fi
62
63 %preun
64 if [ "$1" = "0" ]; then
65         if [ -f /var/lock/subsys/httpd ]; then
66                 /etc/rc.d/init.d/httpd restart 1>&2
67         fi
68 fi
69
70 %files
71 %defattr(644,root,root,755)
72 %doc AUTHOR ChangeLog
73 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.046718 seconds and 2 git commands to generate.