]> git.pld-linux.org Git - packages/apache-mod_fastcgi.git/blob - apache-mod_fastcgi.spec
- apr1 patch
[packages/apache-mod_fastcgi.git] / apache-mod_fastcgi.spec
1 %define         mod_name        fastcgi
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Support for the FastCGI protocol for apache webserver
4 Summary(pl):    Obs³uga protoko³u FastCGI dla serwera apache
5 Summary(ru):    FastCGI - ÂÏÌÅÅ ÂÙÓÔÒÁÑ ×ÅÒÓÉÑ CGI
6 Summary(uk):    FastCGI - Â¦ÌØÛ Û×ÉÄËÁ ×ÅÒӦѠCGI
7 Name:           apache-mod_%{mod_name}
8 # NOTE: remember about apache1-mod_fastcgi.spec when messing here
9 Version:        2.4.2
10 Release:        4
11 License:        distributable
12 Group:          Networking/Daemons
13 Source0:        http://www.FastCGI.com/dist/mod_%{mod_name}-%{version}.tar.gz
14 # Source0-md5:  e994414304b535cb99e10b7d1cad1d1e
15 Patch0:         %{name}-allow-uid-gid.patch
16 Patch1:         %{name}-apr1.patch
17 Source1:        %{name}.conf
18 URL:            http://www.FastCGI.com/
19 BuildRequires:  %{apxs}
20 BuildRequires:  apache-devel >= 2
21 BuildRequires:  libtool
22 Requires(post,preun):   %{apxs}
23 Requires:       apache >= 2
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR)
27 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
28
29 %description
30 This 3rd party module provides support for the FastCGI protocol.
31 FastCGI is a language independent, scalable, open extension to CGI
32 that provides high performance and persistence without the limitations
33 of server specific APIs.
34
35 %description -l pl
36 To jest modu³ apache dodaj±cy obs³ugê protoko³u FastCGI. FastCGI jest
37 niezale¿nym od jêzyka, skalowalnym, otwartym rozszerzeniem CGI daj±cym
38 du¿± wydajno¶æ bez ograniczania API specyficznego dla serwera.
39
40 %description -l ru
41 FastCGI - ÒÁÓÛÉÒÅÎÉÅ CGI, ËÏÔÏÒÏÅ ÐÒÅÄÏÓÔÁ×ÌÑÅÔ ×ÏÚÍÏÖÎÏÓÔØ ÓÏÚÄÁ×ÁÔØ
42 ×ÙÓÏËÏÐÒÏÉÚ×ÏÄÉÔÅÌØÎÙÅ Internet-ÐÒÉÌÏÖÅÎÉÑ ÂÅÚ ÎÅÏÂÈÏÄÉÍÏÓÔÉ
43 ÉÓÐÏÌØÚÏ×ÁÔØ ÓÐÅÃÉÆÉÞÅÓËÉÅ ÄÌÑ ËÁÖÄÏÇÏ web-ÓÅÒ×ÅÒÁ API.
44
45 óËÏÒÏÓÔØ API web-ÓÅÒ×ÅÒÏ× ÓÏ ×ÓÅÍÉ ÐÒÅÉÍÕÝÅÓÔ×ÁÍÉ CGI.
46
47 %description -l uk
48 FastCGI - ÒÏÚÛÉÒÅÎÎÑ CGI, ÑËÅ ÎÁÄÁ¤ ÍÏÖÌÉצÓÔØ ÓÔ×ÏÒÀ×ÁÔÉ
49 ×ÉÓÏËÏÐÒÏÄÕËÔÉ×Φ Internet-ÐÒÏÇÒÁÍÉ ÂÅÚ ÎÅÏÂȦÄÎÏÓÔ¦ ×ÉËÏÒÉÓÔÁÎÎÑ
50 ÓÐÅÃÉƦÞÎÉÈ ÄÌÑ ËÏÖÎÏÇÏ web-ÓÅÒ×ÅÒÕ API.
51
52 û×ÉÄ˦ÓÔØ API web-ÓÅÒ×ÅҦנڦ ×Ó¦ÍÁ ÐÅÒÅ×ÁÇÁÍÉ CGI.
53
54 %prep
55 %setup -q -n mod_%{mod_name}-%{version}
56 %patch0 -p1
57 %patch1 -p1
58
59 %build
60 %{__make} -f Makefile.AP2 \
61         top_dir=%{_pkglibdir} \
62         INCLUDES="-I%(%{apxs} -q INCLUDEDIR)"
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
67
68 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
69 install %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/httpd.conf/
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post
75 if [ -f /var/lock/subsys/httpd ]; then
76         /etc/rc.d/init.d/httpd restart 1>&2
77 else
78         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
79 fi
80  
81 %preun
82 if [ "$1" = "0" ]; then
83         if [ -f /var/lock/subsys/httpd ]; then
84                 /etc/rc.d/init.d/httpd restart 1>&2
85         fi
86 fi
87  
88 %files
89 %defattr(644,root,root,755)
90 %doc docs/LICENSE.TERMS CHANGES docs/*.html
91 %attr(755,root,root) %{_pkglibdir}/*.so
92 %config %{_sysconfdir}/httpd.conf/*.conf
This page took 0.099227 seconds and 3 git commands to generate.