]> git.pld-linux.org Git - packages/apache-mod_fastcgi.git/blob - apache-mod_fastcgi.spec
44e4970dc6fad62bf3564a354d47097bd21882bd
[packages/apache-mod_fastcgi.git] / apache-mod_fastcgi.spec
1 %define         apxs    /usr/sbin/apxs
2 %define         _apache1        %(rpm -q apache-devel 2> /dev/null | grep -Eq '\\-2\\.[0-9]+\\.' && echo 0 || echo 1)
3 Summary:        Support for the FastCGI protocol for apache webserver
4 Summary(pl):    Obs³uga protoko³u FastCGI dla serwera apache
5 Summary(ru):    FastCGI - ÂÏÌÅÅ ÂÙÓÔÒÁÑ ×ÅÒÓÉÑ CGI
6 Summary(uk):    FastCGI - Â¦ÌØÛ Û×ÉÄËÁ ×ÅÒӦѠCGI
7 Name:           apache-mod_fastcgi
8 Version:        2.4.2
9 Release:        1
10 License:        distributable
11 Group:          Networking/Daemons
12 Source0:        http://www.FastCGI.com/dist/mod_fastcgi-%{version}.tar.gz
13 # Source0-md5:  e994414304b535cb99e10b7d1cad1d1e
14 Patch0:         %{name}-allow-uid-gid.patch
15 Source1:        70_mod_fastcgi.conf
16 URL:            http://www.FastCGI.com/
17 BuildRequires:  %{apxs}
18 BuildRequires:  apache-devel
19 BuildRequires:  libtool
20 Requires(post,preun):   %{apxs}
21 Requires:       apache >= 1.3.1
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _libexecdir     %{_libdir}/apache
25 %define         _htmldocdir     /home/httpd/manual/mod
26
27 %description
28 This 3rd party module provides support for the FastCGI protocol.
29 FastCGI is a language independent, scalable, open extension to CGI
30 that provides high performance and persistence without the limitations
31 of server specific APIs.
32
33 %description -l pl
34 To jest modu³ apache dodaj±cy obs³ugê protoko³u FastCGI. FastCGI jest
35 niezale¿nym od jêzyka, skalowalnym, otwartym rozszerzeniem CGI daj±cym
36 du¿± wydajno¶æ bez ograniczania API specyficznego dla serwera.
37
38 %description -l ru
39 FastCGI - ÒÁÓÛÉÒÅÎÉÅ CGI, ËÏÔÏÒÏÅ ÐÒÅÄÏÓÔÁ×ÌÑÅÔ ×ÏÚÍÏÖÎÏÓÔØ ÓÏÚÄÁ×ÁÔØ
40 ×ÙÓÏËÏÐÒÏÉÚ×ÏÄÉÔÅÌØÎÙÅ Internet-ÐÒÉÌÏÖÅÎÉÑ ÂÅÚ ÎÅÏÂÈÏÄÉÍÏÓÔÉ
41 ÉÓÐÏÌØÚÏ×ÁÔØ ÓÐÅÃÉÆÉÞÅÓËÉÅ ÄÌÑ ËÁÖÄÏÇÏ web-ÓÅÒ×ÅÒÁ API.
42
43 óËÏÒÏÓÔØ API web-ÓÅÒ×ÅÒÏ× ÓÏ ×ÓÅÍÉ ÐÒÅÉÍÕÝÅÓÔ×ÁÍÉ CGI.
44
45 %description -l uk
46 FastCGI - ÒÏÚÛÉÒÅÎÎÑ CGI, ÑËÅ ÎÁÄÁ¤ ÍÏÖÌÉצÓÔØ ÓÔ×ÏÒÀ×ÁÔÉ
47 ×ÉÓÏËÏÐÒÏÄÕËÔÉ×Φ Internet-ÐÒÏÇÒÁÍÉ ÂÅÚ ÎÅÏÂȦÄÎÏÓÔ¦ ×ÉËÏÒÉÓÔÁÎÎÑ
48 ÓÐÅÃÉƦÞÎÉÈ ÄÌÑ ËÏÖÎÏÇÏ web-ÓÅÒ×ÅÒÕ API.
49
50 û×ÉÄ˦ÓÔØ API web-ÓÅÒ×ÅҦנڦ ×Ó¦ÍÁ ÐÅÒÅ×ÁÇÁÍÉ CGI.
51
52 %prep
53 %setup -q -n mod_fastcgi-%{version}
54 %patch0 -p1
55
56 %build
57 %if %{_apache1}
58 %{apxs} -o mod_fastcgi.so -c *.c
59 %else
60 %{__make} -f Makefile.AP2 top_dir=%{_libexecdir} INCLUDES="-I%{_includedir}/apache"
61 %endif
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT{%{_libexecdir},%{_htmldocdir}}
66
67 %if %{_apache1}
68 install mod_fastcgi.so $RPM_BUILD_ROOT%{_libexecdir}
69 %else
70 install -d $RPM_BUILD_ROOT%{_sysconfdir}/httpd/httpd.conf
71 libtool --mode=install install mod_fastcgi.la $RPM_BUILD_ROOT%{_libexecdir}
72 install %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/httpd.conf/
73 %endif
74
75 install docs/*.html $RPM_BUILD_ROOT%{_htmldocdir}
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post
81 %if %{_apache1}
82 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
83 %endif
84 if [ -f /var/lock/subsys/httpd ]; then
85         /etc/rc.d/init.d/httpd restart 1>&2
86 else
87         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
88 fi
89  
90 %preun
91 if [ "$1" = "0" ]; then
92 %if %{_apache1}
93         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
94 %endif
95         if [ -f /var/lock/subsys/httpd ]; then
96                 /etc/rc.d/init.d/httpd restart 1>&2
97         fi
98 fi
99  
100 %files
101 %defattr(644,root,root,755)
102 %doc docs/LICENSE.TERMS CHANGES
103 %doc %{_htmldocdir}/*
104 %attr(755,root,root) %{_libexecdir}/*
105 %if ! %{_apache1}
106 %config %{_sysconfdir}/httpd/httpd.conf/*.conf
107 %endif
This page took 0.14357 seconds and 2 git commands to generate.