]> git.pld-linux.org Git - packages/apache-mod_epp.git/blame - apache-mod_epp.spec
- fixed md5
[packages/apache-mod_epp.git] / apache-mod_epp.spec
CommitLineData
687cab59 1#
2# TODO:
3# - example/minimal configuration file
4# - review XXX's
5# - better Summary
6#
7%include /usr/lib/rpm/macros.perl
8%define mod_name epp
9%define apxs /usr/sbin/apxs
10Summary: An EPP (Extensible Provisioning Protocol) implementation for Apache2
11#Summary(pl):
12Name: apache-mod_%{mod_name}
13Version: 1.0
14Release: 1
15License: Apache
16Group: Networking/Daemons
17Source0: http://dl.sourceforge.net/aepps/mod_%{mod_name}-%{version}.tar.gz
7646bc8a 18# Source0-md5: 7517dc6c8f135a88da82022b9d512801
687cab59 19# XXX: to be added to docs?
20#Source1: http://dl.sourceforge.net/aepps/epp-erd-20030122.tar.gz
21URL: http://aepps.sourceforge.net/
22BuildRequires: %{apxs}
23BuildRequires: apache-devel >= 2.0.43
24BuildRequires: rpm-perlprov
25Requires(post,preun): %{apxs}
26# XXX: wouldn't requires_eq be more appropiate?
27Requires: apache >= 2.0.43
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%define _pkglibdir %(%{apxs} -q LIBEXECDIR)
31%define _sysconfdir /etc/httpd
32
33%description
34This Apache 2.0 module implements the EPP over TCP protocol as defined
35in draft-ietf-provreg-epp-tcp-05.txt and the session management parts
36of draft-ietf-provreg-epp-0(6|7).txt.
37
38This is *not* a full implementation of EPP, this module just makes it
39possible to write an EPP server as a set of CGI scripts.
40
41# %description -l pl
42# TODO
43
44%prep
45%setup -q -n mod_%{mod_name}-%{version}
46
47%build
48%{apxs} -c mod_%{mod_name}.c
49
50%install
51rm -rf $RPM_BUILD_ROOT
52
53install -D .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
54install -D epptelnet.pl $RPM_BUILD_ROOT%{_bindir}/epptelnet.pl
55install -d $RPM_BUILD_ROOT%{_examplesdir}
56cp -r examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%post
62%{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
63if [ -f /var/lock/subsys/httpd ]; then
64 /etc/rc.d/init.d/httpd restart 1>&2
65fi
66
67%preun
68if [ "$1" = "0" ]; then
69 %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
70 if [ -f /var/lock/subsys/httpd ]; then
71 /etc/rc.d/init.d/httpd restart 1>&2
72 fi
73fi
74
75%files
76%defattr(644,root,root,755)
77%doc README TODO
78%attr(755,root,root) %{_bindir}/*
79%attr(755,root,root) %{_pkglibdir}/*
80%{_examplesdir}/%{name}-%{version}
This page took 0.112151 seconds and 4 git commands to generate.