]> git.pld-linux.org Git - packages/apache-mod_epp.git/blame - apache-mod_epp.spec
- tabs in preamble
[packages/apache-mod_epp.git] / apache-mod_epp.spec
CommitLineData
687cab59 1# TODO:
2# - example/minimal configuration file
687cab59 3%define mod_name epp
4%define apxs /usr/sbin/apxs
737483df 5%include /usr/lib/rpm/macros.perl
687cab59 6Summary: An EPP (Extensible Provisioning Protocol) implementation for Apache2
07cd93ce 7Summary(pl.UTF-8): Implementacja EPP (Extensible Provisioning Protocol) dla Apache2
687cab59 8Name: apache-mod_%{mod_name}
82003490 9Version: 1.2
687cab59 10Release: 1
11License: Apache
12Group: Networking/Daemons
13Source0: http://dl.sourceforge.net/aepps/mod_%{mod_name}-%{version}.tar.gz
82003490
AM
14# Source0-md5: c21073a4025d79f3ac1c293b58132ed7
15Source1: http://dl.sourceforge.net/aepps/epp-erd-20030122.tar.gz
16# Source1-md5: 3d7720410e83fe6e90742119892011e2
687cab59 17URL: http://aepps.sourceforge.net/
18BuildRequires: %{apxs}
19BuildRequires: apache-devel >= 2.0.43
20BuildRequires: rpm-perlprov
20545a98 21BuildRequires: rpmbuild(macros) >= 1.268
737483df 22Requires: apache(modules-api) = %apache_modules_api
687cab59 23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
737483df
ER
25%define _pkglibdir %(%{apxs} -q LIBEXECDIR 2>/dev/null)
26%define _sysconfdir %(%{apxs} -q SYSCONFDIR 2>/dev/null)
687cab59 27
28%description
29This Apache 2.0 module implements the EPP over TCP protocol as defined
30in draft-ietf-provreg-epp-tcp-05.txt and the session management parts
31of draft-ietf-provreg-epp-0(6|7).txt.
32
33This is *not* a full implementation of EPP, this module just makes it
34possible to write an EPP server as a set of CGI scripts.
35
ea01e4d6
JR
36%description -l pl.UTF-8
37Ten moduł Apache 2.0 jest implementacją protokołu EPP po TCP zgodną z
38dokumentem draft-ietf-provreg-epp-tcp-05.txt oraz częściami
39dotyczącymi zarządzania sesją z draft-ietf-provreg-epp-0(6|7).txt.
5d28c916 40
ea01e4d6
JR
41*Nie* jest to pełna implementacja EPP, ten moduł jedynie umożliwia
42pisanie serwera EPP jako zestawu skryptów CGI.
687cab59 43
44%prep
82003490
AM
45%setup -q -n mod_%{mod_name}-%{version} -a1
46sed -i -e 's#MD5_DIGESTSIZE#APR_MD5_DIGESTSIZE#g' *.c
687cab59 47
48%build
49%{apxs} -c mod_%{mod_name}.c
50
51%install
52rm -rf $RPM_BUILD_ROOT
737483df 53install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_bindir},%{_sysconfdir}/httpd.conf,%{_examplesdir}/%{name}-%{version}}
687cab59 54
737483df
ER
55libtool --mode=install install mod_%{mod_name}.la $RPM_BUILD_ROOT%{_pkglibdir}
56rm -f $RPM_BUILD_ROOT%{_pkglibdir}/*.{l,}a
82003490 57
737483df
ER
58install epptelnet.pl $RPM_BUILD_ROOT%{_bindir}
59cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
687cab59 60
737483df
ER
61echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
62 $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/68_mod_%{mod_name}.conf
82003490 63
687cab59 64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%post
20545a98 68%service -q httpd restart
687cab59 69
335d68d6 70%postun
687cab59 71if [ "$1" = "0" ]; then
20545a98 72 %service -q httpd restart
687cab59 73fi
74
75%files
76%defattr(644,root,root,755)
82003490 77%doc README TODO epp-erd*
737483df 78%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
82003490 79%attr(755,root,root) %{_pkglibdir}/*.so
737483df 80%attr(755,root,root) %{_bindir}/*
687cab59 81%{_examplesdir}/%{name}-%{version}
This page took 0.125978 seconds and 4 git commands to generate.