]> git.pld-linux.org Git - packages/apache-mod_cvs.git/blob - apache-mod_cvs.spec
- changed all BuildRoot definitons
[packages/apache-mod_cvs.git] / apache-mod_cvs.spec
1 %define         mod_name        cvs
2 Summary:        Apache module: Automatically updates files in a CVS-based webtree.
3 Summary(pl):    Modu³ do apache: Automatyczne uaktualnianie plików z drzewa CVS
4 Name:           apache-mod_%{mod_name}
5 Version:        0.4
6 Release:        1
7 Copyright:      GPL
8 Group:          Networking/Daemons
9 Group(pl):      Sieciowe/Serwery
10 Source0:        mod_%{mod_name}-%{version}.tar.gz
11 URL:            http://www.sub.nu/mod_cvs/
12 BuildRequires:  /usr/sbin/apxs
13 BuildRequires:  apache-devel
14 BuildRequires:  zlib-devel
15 Prereq:         %{_sbindir}/apxs
16 BuildRequires:  %{_sbindir}/apxs
17 Requires:       apache
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
21
22 %description
23 Apache module: On-the-fly decompression of HTML documents.
24
25 %description -l pl
26 Modu³ do apache: dekompresuje dokumenty HTML w locie.
27
28 %prep 
29 %setup -q -n mod_%{mod_name}-%{version}
30
31 %build
32 /usr/sbin/apxs -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lz
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36
37 install -d $RPM_BUILD_ROOT%{_pkglibdir}
38
39 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
40
41 strip --strip-unneeded $RPM_BUILD_ROOT%{_pkglibdir}/* 
42
43 %post
44 /usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
45 if [ -f /var/lock/subsys/httpd ]; then
46         /etc/rc.d/init.d/httpd restart 1>&2
47 fi
48
49 %preun
50 if [ "$1" = "0" ]; then
51         /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
52         if [ -f /var/lock/subsys/httpd ]; then
53                 /etc/rc.d/init.d/httpd restart 1>&2
54         fi
55 fi
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.053643 seconds and 3 git commands to generate.