]> git.pld-linux.org Git - packages/apache-mod_clamav.git/blob - apache-mod_clamav.spec
- added Date tag, removed COPYING (just GPL) and INSTALL (generic) from doc
[packages/apache-mod_clamav.git] / apache-mod_clamav.spec
1 %define         apxs            /usr/sbin/apxs
2 %define         mod_name        clamav
3 Summary:        An Apache virus scanning filter
4 Summary(pl):    Filtr skanera antywirusowego dla Apache'a
5 Name:           apache-mod_%{mod_name}
6 Version:        0.12
7 Release:        1
8 License:        GPL
9 Group:          Networking/Daemons
10 Source0:        http://software.othello.ch/mod_clamav/mod_%{mod_name}-%{version}.tar.gz
11 Source1:        %{name}.conf
12 Patch0:         %{name}-libtool-tag.patch
13 URL:            http://software.othello.ch/mod_clamav/
14 BuildRequires:  %{apxs}
15 BuildRequires:  apache-devel >= 2.0
16 BuildRequires:  apr-devel
17 BuildRequires:  apr-util-devel
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 Requires:       apache >= 2
21 Requires:       apache-mod_proxy
22 Requires:       clamav
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
26 %define         _sysconfdir     /etc/httpd
27 %define         _libexecdir     %{_libdir}/apache
28
29 %description
30 mod_clamav is an Apache 2 filter which scans the content delivered by
31 the proxy module (mod_proxy) for viruses using the Clamav virus
32 scanning engine.
33
34 %description -l pl
35 mod_clamav to filtr dla serwera Apache 2 skanuj±cy tre¶ci dostarczane
36 przez modu³ proxy (mod_proxy) pod k±tem wirusów przy u¿yciu silnika
37 skanera antywirusowego Clamav.
38
39 %prep
40 %setup -q -n mod_%{mod_name}-%{version}
41 %patch0 -p0
42
43 %build
44 %{__aclocal}
45 %{__autoconf}
46 %{__automake}
47
48 CPPFLAGS="-I `/usr/bin/apr-config --includedir` -I `/usr/bin/apu-config --includedir`"
49 export CPPFLAGS
50
51 %configure \
52         --with-apxs=%{apxs}
53
54 %{__make}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
59
60 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
61
62 CFG="$RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf"
63 install %{SOURCE1} ${CFG}/32_mod_clamav.conf
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %post
69 if [ -f /var/lock/subsys/httpd ]; then
70         /etc/rc.d/init.d/httpd restart 1>&2
71 else
72         echo "Run \"/etc/rc.d/init.d/httpd start\" to start apache http daemon."
73 fi
74
75 %preun
76 if [ "$1" = "0" ]; then
77         if [ -f /var/lock/subsys/httpd ]; then
78                 /etc/rc.d/init.d/httpd restart 1>&2
79         fi
80 fi
81
82 %files
83 %defattr(644,root,root,755)
84 %doc AUTHORS ChangeLog mod_clamav.html NEWS README TODO
85 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd.conf/32_mod_clamav.conf
86 %attr(755,root,root) %{_libexecdir}/mod_%{mod_name}.so
This page took 0.038033 seconds and 3 git commands to generate.