]> git.pld-linux.org Git - packages/apache-mod_clamav.git/blob - apache-mod_clamav.spec
- use %service
[packages/apache-mod_clamav.git] / apache-mod_clamav.spec
1 # TODO
2 # - fix build with new apache/apr (apr_off_t)
3 %define         apxs            /usr/sbin/apxs
4 %define         mod_name        clamav
5 Summary:        An Apache virus scanning filter
6 Summary(pl):    Filtr skanera antywirusowego dla Apache'a
7 Name:           apache-mod_%{mod_name}
8 Version:        0.21
9 Release:        0.1
10 License:        GPL
11 Group:          Networking/Daemons
12 Source0:        http://software.othello.ch/mod_clamav/mod_%{mod_name}-%{version}.tar.gz
13 # Source0-md5:  98bd0d8628be8ddeae21da6623e57d20
14 Source1:        %{name}.conf
15 Patch0:         %{name}-libtool-tag.patch
16 URL:            http://software.othello.ch/mod_clamav/
17 BuildRequires:  %{apxs}
18 BuildRequires:  apache-devel >= 2.0
19 BuildRequires:  apr-devel >= 1:1.0
20 BuildRequires:  apr-util-devel >= 1:1.0
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  clamav-devel
24 BuildRequires:  libtool
25 BuildRequires:  rpmbuild(macros) >= 1.268
26 Requires:       apache(modules-api) = %apache_modules_api
27 Requires:       apache-mod_proxy
28 Requires:       clamav
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
32 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
33
34 %description
35 mod_clamav is an Apache 2 filter which scans the content delivered by
36 the proxy module (mod_proxy) for viruses using the Clamav virus
37 scanning engine.
38
39 %description -l pl
40 mod_clamav to filtr dla serwera Apache 2 skanuj±cy tre¶ci dostarczane
41 przez modu³ proxy (mod_proxy) pod k±tem wirusów przy u¿yciu silnika
42 skanera antywirusowego Clamav.
43
44 %prep
45 %setup -q -n mod_%{mod_name}-%{version}
46 %patch0 -p0
47
48 %build
49 %{__libtoolize}
50 %{__aclocal}
51 %{__autoconf}
52 %{__automake}
53
54 CPPFLAGS="-I `/usr/bin/apr-1-config --includedir` -I `/usr/bin/apu-1-config --includedir`"
55 %configure \
56         --with-apxs=%{apxs}
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
62
63 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
64 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/32_mod_clamav.conf
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 %service -q httpd restart
71
72 %preun
73 if [ "$1" = "0" ]; then
74         %service -q httpd restart
75 fi
76
77 %files
78 %defattr(644,root,root,755)
79 %doc AUTHORS ChangeLog mod_clamav.html NEWS README TODO
80 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
81 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.068936 seconds and 3 git commands to generate.