]> git.pld-linux.org Git - packages/apache-mod_bw.git/blob - apache-mod_bw.spec
- release 4
[packages/apache-mod_bw.git] / apache-mod_bw.spec
1 # TODO:
2 # - cron?
3 %define         mod_name        bw
4 %define         apxs            /usr/sbin/apxs
5 Summary:        Apache module: bandwidth limits
6 Summary(pl.UTF-8):      Moduł do Apache: limity pasma
7 Name:           apache-mod_%{mod_name}
8 Version:        0.92
9 Release:        4
10 License:        Apache v2.0
11 Group:          Networking/Daemons/HTTP
12 Source0:        http://ivn.cl/files/source/mod_bw-%{version}.tgz
13 # Source0-md5:  90f5e632dad5de8d49dcdb61453dcf97
14 Source1:        %{name}.conf
15 Source2:        %{name}.tmpfiles
16 URL:            http://www.ivn.cl/apache/
17 BuildRequires:  %{apxs}
18 BuildRequires:  apache-devel >= 2.0.0
19 BuildRequires:  rpmbuild(macros) >= 1.268
20 BuildRequires:  sed >= 4.0
21 Requires:       apache(modules-api) = %apache_modules_api
22 Requires:       crondaemon
23 Requires:       procps
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
27 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
28
29 %description
30 "Mod_bandwidth" is a module for the Apache webserver that enable the
31 setting of server-wide or per connection bandwidth limits, based on
32 the directory, size of files and remote IP/domain.
33
34 %description -l pl.UTF-8
35 Moduł pozwalający na ograniczanie pasma serwera Apache bazując na
36 katalogu, wielkości plików lub zdalnym IP/domenie.
37
38 %prep
39 %setup -qc
40
41 %build
42 %{apxs} -c mod_bw.c
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}} \
47         $RPM_BUILD_ROOT%{_var}/run/%{name}/{link,master} \
48         $RPM_BUILD_ROOT{/etc/cron.d,%{_sbindir}} \
49         $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
50
51 install -p .libs/mod_bw.so $RPM_BUILD_ROOT%{_pkglibdir}/mod_%{mod_name}.so
52 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/97_mod_%{mod_name}.conf
53 install %{SOURCE2} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post
59 %service -q httpd restart
60
61 %postun
62 if [ "$1" = "0" ]; then
63         %service -q httpd restart
64 fi
65
66 %files
67 %defattr(644,root,root,755)
68 %doc mod_bw.txt LICENSE ChangeLog
69 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
70 %attr(755,root,root) %{_pkglibdir}/*.so
71 #%config(noreplace) %verify(not size mtime md5) %attr(640,root,root) /etc/cron.d/%{name}
72 #%attr(755,root,root) %{_sbindir}/*
73 /usr/lib/tmpfiles.d/%{name}.conf
74 %attr(750,http,root) %dir %{_var}/run/%{name}
75 %attr(750,http,root) %dir %{_var}/run/%{name}/link
76 %attr(750,http,root) %dir %{_var}/run/%{name}/master
This page took 0.129335 seconds and 3 git commands to generate.