]> git.pld-linux.org Git - packages/apache-mod_authnz_external.git/blob - apache-mod_authnz_external.spec
- HTTP group
[packages/apache-mod_authnz_external.git] / apache-mod_authnz_external.spec
1 %define mod_name        authnz_external
2 %define apxs            /usr/sbin/apxs
3 Summary:        Basic authentication for the Apache Web server using arbitrary shell commands
4 Summary(cs.UTF-8):      Základní autentizace pro WWW server Apache pomocí shellových příkazů
5 Summary(da.UTF-8):      En autenticeringsmodul for webtjeneren Apache hvor man kan bruge vilkårlige skal-kommandoer
6 Summary(de.UTF-8):      Authentifizierung für den Apache Web-Server, der arbiträre Shell-Befehle verwendet
7 Summary(fr.UTF-8):      Authentification de base pour le serveur Web Apache utilisant des commandes shell arbitraires
8 Summary(it.UTF-8):      Autenticazione di base per il server Web Apache mediante comandi arbitrari della shell
9 Summary(nb.UTF-8):      En autentiseringsmodul for webtjeneren Apache der en kan bruke skall-kommandoer
10 Summary(pl.UTF-8):      Podstawowy moduł uwierzytelnienia dla Apache, używający poleceń powłoki
11 Summary(pt.UTF-8):      Um módulo de autenticação de LDAP para o servidor Web Apache
12 Summary(sl.UTF-8):      Osnovna avtentikacija za spletni strežnik Apache, z uporabo poljubnih lupinskih ukazov
13 Summary(sv.UTF-8):      Grundläggande autentisering för webbservern Apache med valfria skalkommandon
14 Name:           apache-mod_%{mod_name}
15 Version:        3.1.0
16 Release:        1
17 License:        BSD
18 Group:          Networking/Daemons/HTTP
19 Source0:        http://unixpapa.com/software/mod_%{mod_name}-%{version}.tar.gz
20 # Source0-md5:  5051bffe6a3992336f4a9f84430a58d2
21 URL:            http://unixpapa.com/mod_auth_external.html
22 BuildRequires:  %{apxs}
23 BuildRequires:  apache-devel >= 2.2
24 BuildRequires:  rpmbuild(macros) >= 1.268
25 Requires:       apache(modules-api) = %apache_modules_api
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
29 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
30
31 %description
32 This module allows you to use any command line program to authenticate
33 a user.
34
35 %description -l cs.UTF-8
36 Balíček mod_auth_external slouží pro omezení přístupu k dokumentům,
37 které poskytuje WWW server Apache. Jména a hesla jsou kontrolována
38 pomocí jakéhokoliv příkazu (jeho návratovým kódem).
39
40 %description -l de.UTF-8
41 Mod_auth_external kann verwendet werden, um den Zugriff auf von einem
42 Web- Server bediente Dokumente zu beschränken, indem es den Rückcode
43 eines gegebenen arbiträren Befehls prüft.
44
45 %description -l es.UTF-8
46 Mod_auth_external puede usarse para limitar el acceso a documentos
47 servidos desde un servidor web verificando el código de retorno de un
48 comando arbitrario especificado.
49
50 %description -l fr.UTF-8
51 Mod_auth_external peut être utilisé pour limiter l'accès à des
52 documents servis par un serveur Web en vérifiant le code de retour
53 d'une commande spécifiée arbitraire.
54
55 %description -l it.UTF-8
56 Mod_auth_external può essere utilizzato per limitare l'accesso ai
57 documenti serviti da un server Web controllando il codice di ritorno
58 di un dato comando arbitrario.
59
60 %description -l ja.UTF-8
61 Mod_auth_external
62 は任意に指定されたコマンドの戻りコードをチェックすること によって、Web
63 サーバーが提供するドキュメントへのアクセスを制限すること ができます。
64
65 %description -l pl.UTF-8
66 Ten moduł pozwala na użycie dowolnego programu działającego z linii
67 poleceń do uwierzytelniania użytkownika.
68
69 %description -l sv.UTF-8
70 Mod_auth_external kan användas för att begränsa åtkomsten till
71 dokument servade av en webbserver genom att kontrollera returkoden
72 från ett godtyckligt angivet kommando.
73
74 %prep
75 %setup -q -n mod_%{mod_name}-%{version}
76
77 %build
78 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.la
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
83
84 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
85 echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
86         $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/90_mod_%{mod_name}.conf
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post
92 %service -q httpd restart
93
94 %postun
95 if [ "$1" = "0" ]; then
96         %service -q httpd restart
97 fi
98
99 %files
100 %defattr(644,root,root,755)
101 %doc TODO AUTHENTICATORS CHANGES README INSTALL test mysql
102 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
103 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.06908 seconds and 3 git commands to generate.