]> git.pld-linux.org Git - packages/apache-mod_authn_sasl.git/blob - apache-mod_authn_sasl.spec
- added docs
[packages/apache-mod_authn_sasl.git] / apache-mod_authn_sasl.spec
1 %define mod_name        authn_sasl
2 %define apxs            /usr/sbin/apxs
3 Summary:        Basic authentication for the Apache Web server using SASL
4 Summary(pl.UTF-8):      Podstawowe uwierzytelnianie (Basic) dla serwera WWW Apache przy użyciu SASL
5 Name:           apache-mod_%{mod_name}
6 Version:        1.2
7 Release:        1
8 License:        Apache v2.0
9 Group:          Networking/Daemons/HTTP
10 Source0:        https://downloads.sourceforge.net/mod-authn-sasl/mod_authn_sasl-%{version}.tar.bz2
11 # Source0-md5:  089e86b47b1e82b2a2955459b5caec98
12 URL:            https://mod-authn-sasl.sourceforge.net/
13 BuildRequires:  %{apxs}
14 BuildRequires:  apache-devel >= 2.2
15 BuildRequires:  cyrus-sasl-devel >= 2
16 BuildRequires:  rpmbuild(macros) >= 1.268
17 Requires:       apache(modules-api) = %apache_modules_api
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
21 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
22
23 %description
24 This module allows you to use SASL to authenticate a user.
25
26 %description -l pl.UTF-8
27 Ten moduł umożliwia używanie SASL do uwierzytelniania użytkownika.
28
29 %prep
30 %setup -q -n mod_%{mod_name}-%{version}
31
32 %build
33 %{apxs} -c mod_%{mod_name}.c -o mod_%{mod_name}.la -lsasl2
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
38
39 install -p .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
40 echo 'LoadModule %{mod_name}_module modules/mod_%{mod_name}.so' > \
41         $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %post
47 %service -q httpd restart
48
49 %postun
50 if [ "$1" = "0" ]; then
51         %service -q httpd restart
52 fi
53
54 %files
55 %defattr(644,root,root,755)
56 %doc AUTHORS Changelog
57 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/90_mod_%{mod_name}.conf
58 %attr(755,root,root) %{_pkglibdir}/mod_authn_sasl.so
This page took 0.095015 seconds and 3 git commands to generate.