]> git.pld-linux.org Git - packages/apache-mod_auth_pgsql.git/blob - apache-mod_auth_pgsql.spec
- unified files
[packages/apache-mod_auth_pgsql.git] / apache-mod_auth_pgsql.spec
1 %define         mod_name        auth_pgsql
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the PostgreSQL authentication module for Apache
4 Summary(cs):    Základní autentizace pro WWW server Apache pomocí PostgreSQL
5 Summary(da):    Autenticering for webtjeneren Apache fra en PostgreSQL-database
6 Summary(de):    Authentifizierung für den Apache Web-Server, der eine PostgreSQL-Datenbank verwendet
7 Summary(es):    Autenticación vía PostgreSQL para Apache
8 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant une base de données PostgreSQL
9 Summary(it):    Autenticazione di base per il server web Apache mediante un database PostgreSQL
10 Summary(ja):    PostgreSQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò»È¤Ã¤¿ Apache Web ¥µ¡¼¥Ð¡¼¤Ø¤Î´ðËÜǧ¾Ú
11 Summary(nb):    Autentisering for webtjeneren Apache fra en PostgreSQL-database
12 Summary(pl):    Modu³ uwierzytelnienia PostgreSQL dla Apache
13 Summary(pt_BR): Autenticação via PostgreSQL para o Apache
14 Summary(sv):    Grundläggande autenticering till webbservern Apache med en PostgreSQL-databas
15 Name:           apache-mod_%{mod_name}
16 Version:        2.0.2
17 %define _beta   b1
18 Release:        0.%{_beta}.1
19 License:        GPL
20 Group:          Networking/Daemons
21 Source0:        http://www.giuseppetanzilli.it/mod_auth_pgsql2/dist/mod_%{mod_name}-%{version}%{_beta}.tar.gz
22 # Source0-md5:  8216fde4597c288537ff4fec508a4b41
23 Source1:        apache-mod_auth_pgsql.conf
24 Patch0:         apache-mod_auth_pgsql.patch
25 URL:            http://www.giuseppetanzilli.it/mod_auth_pgsql2/
26 BuildRequires:  %{apxs}
27 BuildRequires:  apache-devel >= 2.0.52-2
28 BuildRequires:  postgresql-devel
29 Requires:       apache(modules-api) = %apache_modules_api
30 Obsoletes:      mod_auth_pgsql
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
34 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
35
36 %description
37 This is an authentication module for Apache that allows you to
38 authenticate HTTP clients using PostgreSQL RDBMS.
39
40 %description -l cs
41 Balíèek mod_auth_pgsql slou¾í pro omezení pøístupu k dokumentùm, které
42 poskytuje WWW server Apache. Jména a hesla jsou ulo¾ena v databázi
43 PostgreSQL.
44
45 %description -l de
46 Mod_auth_pgsql kann verwendet werden, um den Zugriff auf von einem
47 Web- Server bediente Dokumente zu beschränken, indem es die Felder in
48 einer Tabelle in einer PostgresQL-Datenbank prüft.
49
50 %description -l es
51 Mod_auth_pgsql puede usarse para limitar el acceso a documentos
52 servidos desde un servidor web verificando datos en una base de datos
53 PostgreSQL.
54
55 %description -l fr
56 mod_auth_pgsql peut être utilisé pour limiter l'accès à des documents
57 servis par un serveur Web en vérifiant des champs dans une table d'une
58 base de données PostgresQL.
59
60 %description -l it
61 Mod_auth_pgsql può essere usato per limitare l'accesso a documenti
62 serviti da un server Web controllando i campi di una tabella in un
63 database PostgresQL.
64
65 %description -l ja
66 Mod_auth_pgsql ¤Ï¡¢PostgresQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤Î¥Æ¡¼¥Ö¥ë¤ÎÃæ¤Î¥Õ¥£¡¼¥ë¥É¤ò
67 ¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ëʸ½ñ¤Ø¤Î¥¢¥¯¥»¥¹¤ò
68 À©¸Â¤Ç¤­¤Þ¤¹¡£
69
70 %description -l pl
71 To jest modu³ uwierzytelnienia dla Apache pozwalaj±cy na
72 uwierzytelnianie klientów HTTP z u¿yciem bazy danych PostgreSQL.
73
74 %description -l pt_BR
75 Com o mod_auth_pgsql você pode fazer autenticação no Apache usando o
76 PostgreSQL.
77
78 %description -l sv
79 Mod_auth_pgsql kan användas för att begränsa åtkomsten till dokument
80 servade av en webbserver genom att kontrollera data i en
81 PostgreSQL-databas.
82
83 %prep
84 %setup -q -n mod_%{mod_name}-%{version}%{_beta}
85 %patch0 -p1
86
87 %build
88 %{apxs} \
89         -I%{_includedir}/postgresql \
90         -lpq \
91         -c mod_%{mod_name}.c \
92         -o mod_%{mod_name}.la
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
97
98 install .libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
99 install %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/httpd.conf/52_mod_auth_pgsql.conf
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post
105 if [ -f /var/lock/subsys/httpd ]; then
106         /etc/rc.d/init.d/httpd restart 1>&2
107 fi
108
109 %preun
110 if [ "$1" = "0" ]; then
111         if [ -f /var/lock/subsys/httpd ]; then
112                 /etc/rc.d/init.d/httpd restart 1>&2
113         fi
114 fi
115
116 %files
117 %defattr(644,root,root,755)
118 %doc *.html
119 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_auth_pgsql.conf
120 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.099928 seconds and 3 git commands to generate.