]> git.pld-linux.org Git - packages/apache-mod_auth_pgsql.git/blob - apache-mod_auth_pgsql.spec
- initial release
[packages/apache-mod_auth_pgsql.git] / apache-mod_auth_pgsql.spec
1 %define         mod_name        auth_pgsql
2 Summary:        This is the PgSQL authentication module for Apache
3 Name:           apache-mod_%{mod_name}
4 Version:        0.9.10
5 Release:        1
6 License:        GPL
7 Group:          Networking/Daemons
8 Group(de):      Netzwerkwesen/Server
9 Group(pl):      Sieciowe/Serwery
10 Source0:        http://www.giuseppetanzilli.it/mod_%{mod_name}/dist/mod_%{mod_name}-%{version}.tar.gz
11 Patch0:         %{name}-version.patch
12 BuildRequires:  postgresql-devel
13 BuildRequires:  /usr/sbin/apxs
14 BuildRequires:  apache(EAPI)-devel
15 Prereq:         /usr/sbin/apxs
16 Requires:       apache(EAPI)
17 URL:            http://www.giuseppetanzilli.it/mod_auth_pgsql/
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
21
22 %description
23 This is an authentication module for Apache that allows you to
24 authenticate HTTP clients using postgresql RDBMS.
25
26 %prep 
27 %setup -q -n "mod_%{mod_name}-%{version}"
28 %patch0 -p1
29
30 %build
31 /usr/sbin/apxs \
32         -I /usr/include/postgresql \
33         -l pq \
34         -c mod_%{mod_name}.c \
35         -o mod_%{mod_name}.so
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT%{_pkglibdir}
40
41 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
42
43 %post
44 /usr/sbin/apxs -e -a -n auth_pgsql %{_pkglibdir}/mod_%{mod_name}.so 1>&2
45 if [ -f /var/lock/subsys/httpd ]; then
46         /etc/rc.d/init.d/httpd restart 1>&2
47 fi
48
49 %preun
50 if [ "$1" = "0" ]; then
51         /usr/sbin/apxs -e -A -n auth_pgsql %{_pkglibdir}/mod_%{mod_name}.so 1>&2
52         if [ -f /var/lock/subsys/httpd ]; then
53                 /etc/rc.d/init.d/httpd restart 1>&2
54         fi
55 fi
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.089516 seconds and 3 git commands to generate.