]> git.pld-linux.org Git - packages/apache-mod_auth_pgsql.git/blob - apache-mod_auth_pgsql.spec
- more specific Requires
[packages/apache-mod_auth_pgsql.git] / apache-mod_auth_pgsql.spec
1 %define         mod_name        auth_pgsql
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the PostgreSQL authentication module for Apache
4 Summary(cs):    Základní autentizace pro WWW server Apache pomocí PostgreSQL
5 Summary(da):    Autenticering for webtjeneren Apache fra en PostgreSQL-database
6 Summary(de):    Authentifizierung für den Apache Web-Server, der eine PostgreSQL-Datenbank verwendet
7 Summary(es):    Autenticación vía PostgreSQL para Apache
8 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant une base de données PostgreSQL
9 Summary(it):    Autenticazione di base per il server web Apache mediante un database PostgreSQL
10 Summary(ja):    PostgreSQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò»È¤Ã¤¿ Apache Web ¥µ¡¼¥Ð¡¼¤Ø¤Î´ðËÜǧ¾Ú
11 Summary(no):    Autentisering for webtjeneren Apache fra en PostgreSQL-database
12 Summary(pl):    Modu³ autentykacji PostgreSQL dla Apache
13 Summary(pt_BR): Autenticação via PostgreSQL para o Apache
14 Summary(sv):    Grundläggande autenticering till webbservern Apache med en PostgreSQL-databas
15 Name:           apache-mod_%{mod_name}
16 Version:        0.9.12
17 Release:        4
18 License:        GPL
19 Group:          Networking/Daemons
20 Source0:        http://www.giuseppetanzilli.it/mod_%{mod_name}/dist/mod_%{mod_name}-%{version}.tar.gz
21 # Source0-md5:  7be403b7487c13cdb023cc526ee2e13a
22 URL:            http://www.giuseppetanzilli.it/mod_auth_pgsql/
23 BuildRequires:  %{apxs}
24 BuildRequires:  apache(EAPI)-devel
25 BuildRequires:  postgresql-devel
26 Requires(post,preun):   %{apxs}
27 Requires:       apache(EAPI)
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29 Obsoletes:      mod_auth_pgsql
30
31 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
32
33 %description
34 This is an authentication module for Apache that allows you to
35 authenticate HTTP clients using postgresql RDBMS.
36
37 %description -l cs
38 Balíèek mod_auth_pgsql slou¾í pro omezení pøístupu k dokumentùm, které
39 poskytuje WWW server Apache. Jména a hesla jsou ulo¾ena v databázi
40 PostgreSQL.
41
42 %description -l de
43 Mod_auth_pgsql kann verwendet werden, um den Zugriff auf von einem
44 Web- Server bediente Dokumente zu beschränken, indem es die Felder in
45 einer Tabelle in einer PostgresQL-Datenbank prüft.
46
47 %description -l es
48 Mod_auth_pgsql puede usarse para limitar el acceso a documentos
49 servidos desde un servidor web verificando datos en una base de datos
50 PostgreSQL.
51
52 %description -l fr
53 mod_auth_pgsql peut être utilisé pour limiter l'accès à des documents
54 servis par un serveur Web en vérifiant des champs dans une table d'une
55 base de données PostgresQL.
56
57 %description -l it
58 Mod_auth_pgsql può essere usato per limitare l'accesso a documenti
59 serviti da un server Web controllando i campi di una tabella in un
60 database PostgresQL.
61
62 %description -l ja
63 Mod_auth_pgsql ¤Ï¡¢PostgresQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤Î¥Æ¡¼¥Ö¥ë¤ÎÃæ¤Î¥Õ¥£¡¼¥ë¥É¤ò
64 ¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ëʸ½ñ¤Ø¤Î¥¢¥¯¥»¥¹¤ò
65 À©¸Â¤Ç¤­¤Þ¤¹¡£
66
67 %description -l pl
68 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
69 klientów HTTP z u¿yciem bazy danych postgresql.
70
71 %description -l pt_BR
72 Com o mod_auth_pgsql você pode fazer autenticação no Apache usando o
73 PostgreSQL.
74
75 %description -l sv
76 Mod_auth_pgsql kan användas för att begränsa åtkomsten till dokument
77 servade av en webbserver genom att kontrollera data i en
78 PostgreSQL-databas.
79
80 %prep
81 %setup -q -n "mod_%{mod_name}-%{version}"
82
83 %build
84 %{apxs} \
85         -I %{_includedir}/postgresql \
86         -l pq \
87         -c mod_%{mod_name}.c \
88         -o mod_%{mod_name}.so
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT%{_pkglibdir}
93
94 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post
100 %{apxs} -e -a -n auth_pgsql %{_pkglibdir}/mod_%{mod_name}.so 1>&2
101 if [ -f /var/lock/subsys/httpd ]; then
102         /etc/rc.d/init.d/httpd restart 1>&2
103 fi
104
105 %preun
106 if [ "$1" = "0" ]; then
107         %{apxs} -e -A -n auth_pgsql %{_pkglibdir}/mod_%{mod_name}.so 1>&2
108         if [ -f /var/lock/subsys/httpd ]; then
109                 /etc/rc.d/init.d/httpd restart 1>&2
110         fi
111 fi
112
113 %files
114 %defattr(644,root,root,755)
115 %doc *.html
116 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.105927 seconds and 3 git commands to generate.