]> git.pld-linux.org Git - packages/apache-mod_auth_pgsql.git/blob - apache-mod_auth_pgsql.spec
- updayed to 0.9.12 (bugfix release).
[packages/apache-mod_auth_pgsql.git] / apache-mod_auth_pgsql.spec
1 %define         mod_name        auth_pgsql
2 Summary:        This is the PgSQL authentication module for Apache
3 Summary(pl):    Modu³ autentykacji PgSQL dla Apache
4 Summary(pt_BR): Autenticação via PostgreSQL para o Apache
5 Name:           apache-mod_%{mod_name}
6 Version:        0.9.12
7 Release:        1
8 License:        GPL
9 Group:          Networking/Daemons
10 Group(de):      Netzwerkwesen/Server
11 Group(pl):      Sieciowe/Serwery
12 Source0:        http://www.giuseppetanzilli.it/mod_%{mod_name}/dist/mod_%{mod_name}-%{version}.tar.gz
13 BuildRequires:  postgresql-devel
14 BuildRequires:  /usr/sbin/apxs
15 BuildRequires:  apache(EAPI)-devel
16 Prereq:         /usr/sbin/apxs
17 Requires:       apache(EAPI)
18 URL:            http://www.giuseppetanzilli.it/mod_auth_pgsql/
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
22
23 %description
24 This is an authentication module for Apache that allows you to
25 authenticate HTTP clients using postgresql RDBMS.
26
27 %description -l pl
28 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
29 klientów HTTP z u¿yciem bazy danych postgresql.
30
31 %description -l pt_BR
32 Com o mod_auth_pgsql você pode fazer autenticação no Apache usando o
33 PostgreSQL.
34
35 %prep 
36 %setup -q -n "mod_%{mod_name}-%{version}"
37
38 %build
39 /usr/sbin/apxs \
40         -I %{_includedir}/postgresql \
41         -l pq \
42         -c mod_%{mod_name}.c \
43         -o mod_%{mod_name}.so
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT%{_pkglibdir}
48
49 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %post
55 /usr/sbin/apxs -e -a -n auth_pgsql %{_pkglibdir}/mod_%{mod_name}.so 1>&2
56 if [ -f /var/lock/subsys/httpd ]; then
57         /etc/rc.d/init.d/httpd restart 1>&2
58 fi
59
60 %preun
61 if [ "$1" = "0" ]; then
62         /usr/sbin/apxs -e -A -n auth_pgsql %{_pkglibdir}/mod_%{mod_name}.so 1>&2
63         if [ -f /var/lock/subsys/httpd ]; then
64                 /etc/rc.d/init.d/httpd restart 1>&2
65         fi
66 fi
67
68 %files
69 %defattr(644,root,root,755)
70 %doc *.html
71 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.304559 seconds and 3 git commands to generate.