]> git.pld-linux.org Git - packages/apache-mod_auth_pam.git/blob - apache-mod_auth_pam.spec
- pl translations
[packages/apache-mod_auth_pam.git] / apache-mod_auth_pam.spec
1 %define         mod_name        auth_pam
2 Summary:        This is the PAM authentication module for Apache
3 Summary(pl):    Modu³ autentykacji PAM dla Apache
4 Name:           apache-mod_%{mod_name}
5 Version:        1.0a
6 Release:        1
7 License:        GPL
8 Group:          Networking/Daemons
9 Group(de):      Netzwerkwesen/Server
10 Group(pl):      Sieciowe/Serwery
11 Source0:        http://pam.sourceforge.net/mod_auth_pam/dist/mod_%{mod_name}.tar.gz
12 Patch0:         %{name}-symbol_fix.patch
13 BuildRequires:  /usr/sbin/apxs
14 BuildRequires:  apache(EAPI)-devel
15 Prereq:         /usr/sbin/apxs
16 Requires:       apache(EAPI)
17 URL:            http://pam.sourceforge.net/mod_auth_pam/
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
21
22 %description
23 This is an authentication module for Apache that allows you to
24 authenticate HTTP clients using PAM (pluggable authentication module).
25
26 %description -l pl
27 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
28 klientów HTTP przez PAM.
29
30 %prep 
31 %setup -q -n mod_%{mod_name}-%{version}
32 %patch -p1
33
34 %build
35 /usr/sbin/apxs -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lpam -ldl
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT%{_pkglibdir}
40
41 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
42
43 %post
44 /usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
45 if [ -f /var/lock/subsys/httpd ]; then
46         /etc/rc.d/init.d/httpd restart 1>&2
47 fi
48
49 %preun
50 if [ "$1" = "0" ]; then
51         /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
52         if [ -f /var/lock/subsys/httpd ]; then
53                 /etc/rc.d/init.d/httpd restart 1>&2
54         fi
55 fi
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.147249 seconds and 3 git commands to generate.