]> git.pld-linux.org Git - packages/apache-mod_auth_pam.git/blob - apache-mod_auth_pam.spec
- config manipulation in post/preun scripts replaced by config file
[packages/apache-mod_auth_pam.git] / apache-mod_auth_pam.spec
1 %define         mod_name        auth_pam
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the PAM authentication module for Apache
4 Summary(es):    Este módulo proporciona autenticación PAM para Apache
5 Summary(pl):    Modu³ uwierzytelnienia PAM dla Apache
6 Summary(pt_BR): Este módulo provê autenticação PAM para o Apache
7 Name:           apache-mod_%{mod_name}
8 Version:        2.0
9 Release:        3
10 License:        GPL
11 Group:          Networking/Daemons
12 Source0:        http://pam.sourceforge.net/mod_%{mod_name}/dist/mod_%{mod_name}-%{version}.tar.gz
13 # Source0-md5:  561a495f27e6cc810641bd6ce6db3d02
14 Source1:        apache-mod_auth_pam.conf
15 Patch0:         %{name}-missing_constant.patch
16 URL:            http://pam.sourceforge.net/mod_auth_pam/
17 BuildRequires:  %{apxs}
18 BuildRequires:  apache-devel >= 2
19 Requires:       apache >= 2
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _sysconfdir     /etc/httpd
23 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
24
25 %description
26 This is an authentication module for Apache that allows you to
27 authenticate HTTP clients using PAM (pluggable authentication module).
28
29 %description -l es
30 Este módulo permite autenticar clientes HTTP usando el directorio PAM.
31
32 %description -l pl
33 To jest modu³ uwierzytelnienia dla Apache pozwalaj±cy na
34 uwierzytelnianie klientów HTTP przez PAM.
35
36 %description -l pt_BR
37 Este módulo permite que você autentique clientes HTTP usando o
38 diretório PAM.
39
40 %prep
41 %setup -q -n mod_%{mod_name}/apache-2.0
42 %patch0 -p0
43
44 %build
45 %{apxs} -c mod_%{mod_name}2.c   -o mod_%{mod_name}2.la   -lpam
46 %{apxs} -c mod_auth_etc_group.c -o mod_auth_etc_group.la -lpam
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{_pkglibdir},/etc/pam.d,%{_sysconfdir}/httpd.conf/}
51
52 install .libs/mod_*.so $RPM_BUILD_ROOT%{_pkglibdir}
53 install ../samples/httpd- $RPM_BUILD_ROOT/etc/pam.d/httpd
54 install %SOURCE1 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd.conf/52_mod_auth_pam.conf
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %post
60 if [ -f /var/lock/subsys/httpd ]; then
61         /etc/rc.d/init.d/httpd restart 1>&2
62 fi
63
64 %preun
65 if [ "$1" = "0" ]; then
66         if [ -f /var/lock/subsys/httpd ]; then
67                 /etc/rc.d/init.d/httpd restart 1>&2
68         fi
69 fi
70
71 %files
72 %defattr(644,root,root,755)
73 %doc ../doc/{configure,faq}.txt ../samples/dot-htaccess ../README
74 %config(noreplace) /etc/pam.d/httpd
75 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd.conf/*_mod_auth_pam.conf
76 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 2.150771 seconds and 3 git commands to generate.