]> git.pld-linux.org Git - packages/apache-mod_auth_mysql.git/blob - apache-mod_auth_mysql.spec
- killed pointless obsolete
[packages/apache-mod_auth_mysql.git] / apache-mod_auth_mysql.spec
1 %define         mod_name        auth_mysql
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the MySQL authentication module for Apache
4 Summary(cs):    Základní autentizace pro WWW server Apache pomocí MySQL
5 Summary(da):    Autenticering for webtjeneren Apache fra en MySQL-database
6 Summary(de):    Authentifizierung für den Apache Web-Server, der eine MySQL-Datenbank verwendet
7 Summary(es):    Autenticación vía MySQL para Apache
8 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant une base de données MySQL
9 Summary(it):    Autenticazione di base per il server Web Apache mediante un database MySQL
10 Summary(ja):    MySQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò»È¤Ã¤¿ Apache Web ¥µ¡¼¥Ð¡¼¤Ø¤Î´ðËÜǧ¾Ú
11 Summary(nb):    Autentisering for webtjeneren Apache fra en MySQL-database
12 Summary(pl):    Modu³ uwierzytelnienia MySQL dla Apache
13 Summary(pt_BR): Autenticação via MySQL para o Apache
14 Summary(sv):    Grundläggande autenticering för webbservern Apache med en MySQL-databas
15 Name:           apache-mod_%{mod_name}
16 Version:        4.3.9
17 Release:        0.1
18 License:        GPL
19 Group:          Networking/Daemons
20 Source0:        ftp://ftp.debian.org/debian/pool/main/liba/libapache-mod-auth-mysql/libapache-mod-auth-mysql_%{version}.orig.tar.gz
21 # Source0-md5:  9c1ecbe5fb64d4c93444311ff34bfe35
22 BuildRequires:  %{apxs}
23 BuildRequires:  apache-devel >= 2.0.0
24 BuildRequires:  apr-util >= 1:1.0
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  mysql-devel
28 Requires:       apache >= 2.0.0
29 Requires:       apache-mod_auth
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
33 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
34
35 %description
36 This is an authentication module for Apache that allows you to
37 authenticate HTTP clients using MySQL RDBMS.
38
39 %description -l cs
40 Balíèek mod_auth_mysql slou¾í pro omezení pøístupu k dokumentùm, které
41 poskytuje WWW server Apache. Jména a hesla jsou ulo¾ena v databázi
42 MySQL.
43
44 %description -l de
45 mod_auth_mysql kann verwendet werden, um den Zugriff auf von einem
46 Web- Server bediente Dokumente zu beschränken, indem es die Daten in
47 einer MySQL-Datenbank prüft.
48
49 %description -l es
50 mod_auth_mysql puede usarse para limitar el acceso a documentos
51 servidos por un servidor web verificando datos en una base de datos
52 MySQL.
53
54 %description -l fr
55 mod_auth_mysql peut être utilisé pour limiter l'accès à des documents
56 servis par un serveur Web en vérifiant les données dans une base de
57 données MySQL.
58
59 %description -l it
60 mod_auth_mysql può essere usato per limitare l'accesso a documenti
61 serviti da un server Web controllando i dati in un database MySQL.
62
63 %description -l ja
64 mod_auth_mysql ¤Ï¡¢MySQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤Î¥Ç¡¼¥¿¤ò¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È
65 ¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ë¥É¥­¥å¥á¥ó¥È¤Ø¤Î¥¢¥¯¥»¥¹¤òÀ©¸Â¤¹¤ë¤³¤È
66 ¤¬¤Ç¤­¤Þ¤¹¡£
67
68 %description -l pl
69 To jest modu³ uwierzytelnienia dla Apache pozwalaj±cy na
70 uwierzytelnianie klientów HTTP z u¿yciem bazy danych MySQL.
71
72 %description -l pt_BR
73 Com o mod_auth_mysql você pode fazer autenticação no Apache usando o
74 MySQL.
75
76 %description -l sv
77 mod_auth_mysql kan användas för att begränsa åtkomsten till dokument
78 servade av en webbserver genom att kontrollera data i en
79 MySQL-databas.
80
81 %prep
82 %setup -q -n mod-auth-mysql-%{version}
83
84 %build
85 sed -i -e 's#/usr/bin/apxs2#%{apxs}#g' configure*
86 %configure \
87         --enable-apache2 \
88         --with-apxs=%{apxs} \
89         --with-mysql=%{_prefix}
90 %{apxs} -c -DAPACHE2 -DAPR_XtOffsetOf=APR_OFFSETOF -I %{_includedir}/mysql mod_%{mod_name}.c \
91         `%{_bindir}/apr-1-config --link-ld` `%{_bindir}/apu-1-config --link-ld` -lcrypt -lmysqlclient
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
96
97 libtool install mod_%{mod_name}.la $RPM_BUILD_ROOT%{_pkglibdir}
98
99 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
100         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post
106 if [ -f /var/lock/subsys/apache ]; then
107         /etc/rc.d/init.d/apache restart 1>&2
108 fi
109
110 %postun
111 if [ "$1" = "0" ]; then
112         if [ -f /var/lock/subsys/apache ]; then
113                 /etc/rc.d/init.d/apache restart 1>&2
114         fi
115 fi
116
117 %files
118 %defattr(644,root,root,755)
119 %doc DIRECTIVES USAGE
120 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
121 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.102849 seconds and 3 git commands to generate.