]> git.pld-linux.org Git - packages/apache-mod_auth_mysql.git/blob - apache-mod_auth_mysql.spec
a2ed9bc0060f2015361dffe8d8b724e9 mysql-group-auth.txt
[packages/apache-mod_auth_mysql.git] / apache-mod_auth_mysql.spec
1 %define         mod_name        auth_mysql
2 Summary:        This is the MySQL authentication module for Apache
3 Summary(pl):    Modu³ autentykacji MySQL dla Apache
4 Name:           apache-mod_%{mod_name}
5 Version:        0.3
6 Release:        3
7 License:        GPL
8 Group:          Networking/Daemons
9 Group(de):      Netzwerkwesen/Server
10 Group(pl):      Sieciowe/Serwery
11 Source0:        ftp://ftp.kcilink.com/pub/mod_%{mod_name}.c.gz
12 Patch0:         %{name}-name.patch
13 BuildRequires:  mysql-devel
14 BuildRequires:  /usr/sbin/apxs
15 BuildRequires:  apache(EAPI)-devel
16 Prereq:         /usr/sbin/apxs
17 Requires:       apache(EAPI)
18 URL:            http://modntlm.sourceforge.net/
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _pkglibdir      %(/usr/sbin/apxs -q LIBEXECDIR)
22
23 %description
24 This is an authentication module for Apache that allows you to
25 authenticate HTTP clients using mysql RDBMS.
26
27 %description -l pl
28 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
29 klientów HTTP z u¿yciem bazy danych mysql.
30
31 %prep 
32 %setup -q -T -c
33 gzip -dc %{SOURCE0} > mod_%{mod_name}.c
34 %patch -p1
35
36 %build
37 /usr/sbin/apxs -c mod_%{mod_name}.c -o mod_%{mod_name}.so -lmysqlclient
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT%{_pkglibdir}
42
43 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %post
49 /usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
50 if [ -f /var/lock/subsys/httpd ]; then
51         /etc/rc.d/init.d/httpd restart 1>&2
52 fi
53
54 %preun
55 if [ "$1" = "0" ]; then
56         /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
57         if [ -f /var/lock/subsys/httpd ]; then
58                 /etc/rc.d/init.d/httpd restart 1>&2
59         fi
60 fi
61
62 %files
63 %defattr(644,root,root,755)
64 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.04864 seconds and 3 git commands to generate.