]> git.pld-linux.org Git - packages/apache-mod_auth_mysql.git/blob - apache-mod_auth_mysql.spec
- s/no/nb/ in Summary langs
[packages/apache-mod_auth_mysql.git] / apache-mod_auth_mysql.spec
1 %define         mod_name        auth_mysql
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the MySQL authentication module for Apache
4 Summary(cs):    Základní autentizace pro WWW server Apache pomocí MySQL
5 Summary(da):    Autenticering for webtjeneren Apache fra en MySQL-database
6 Summary(de):    Authentifizierung für den Apache Web-Server, der eine MySQL-Datenbank verwendet
7 Summary(es):    Autenticación vía MySQL para Apache
8 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant une base de données MySQL
9 Summary(it):    Autenticazione di base per il server Web Apache mediante un database MySQL
10 Summary(ja):    MySQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò»È¤Ã¤¿ Apache Web ¥µ¡¼¥Ð¡¼¤Ø¤Î´ðËÜǧ¾Ú
11 Summary(nb):    Autentisering for webtjeneren Apache fra en MySQL-database
12 Summary(pl):    Modu³ autentykacji MySQL dla Apache
13 Summary(pt_BR): Autenticação via MySQL para o Apache
14 Summary(sv):    Grundläggande autenticering för webbservern Apache med en MySQL-databas
15 Name:           apache-mod_%{mod_name}
16 Version:        2.20a
17 Release:        5
18 License:        GPL
19 Group:          Networking/Daemons
20 Source0:        http://web.oyvax.com/src/mod_auth_mysql-%{version}.tar.gz
21 # Source0-md5:  49ca2a43f04939d31512616437f4fbb3
22 URL:            http://www.diegonet.com/support/mod_auth_mysql.shtml
23 BuildRequires:  apache(EAPI)-devel
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  mysql-devel
27 BuildRequires:  %{apxs}
28 Requires(post,preun):   %{_sbindir}/apxs
29 Requires:       apache(EAPI)
30 Requires:       apache-mod_auth
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32 Obsoletes:      mod_auth_mysql
33
34 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
35
36 %description
37 This is an authentication module for Apache that allows you to
38 authenticate HTTP clients using mysql RDBMS.
39
40 %description -l cs
41 Balíèek mod_auth_mysql slou¾í pro omezení pøístupu k dokumentùm, které
42 poskytuje WWW server Apache. Jména a hesla jsou ulo¾ena v databázi
43 MySQL.
44
45 %description -l de
46 mod_auth_mysql kann verwendet werden, um den Zugriff auf von einem
47 Web- Server bediente Dokumente zu beschränken, indem es die Daten in
48 einer MySQL-Datenbank prüft.
49
50 %description -l es
51 mod_auth_mysql puede usarse para limitar el acceso a documentos
52 servidos por un servidor web verificando datos en una base de datos
53 MySQL.
54
55 %description -l fr
56 mod_auth_mysql peut être utilisé pour limiter l'accès à des documents
57 servis par un serveur Web en vérifiant les données dans une base de
58 données MySQL.
59
60 %description -l it
61 mod_auth_mysql può essere usato per limitare l'accesso a documenti
62 serviti da un server Web controllando i dati in un database MySQL.
63
64 %description -l ja
65 mod_auth_mysql ¤Ï¡¢MySQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤Î¥Ç¡¼¥¿¤ò¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È
66 ¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ë¥É¥­¥å¥á¥ó¥È¤Ø¤Î¥¢¥¯¥»¥¹¤òÀ©¸Â¤¹¤ë¤³¤È
67 ¤¬¤Ç¤­¤Þ¤¹¡£
68
69 %description -l pl
70 To jest modu³ autentykacji dla Apache pozwalaj±cy na autentykacjê
71 klientów HTTP z u¿yciem bazy danych mysql.
72
73 %description -l pt_BR
74 Com o mod_auth_mysql você pode fazer autenticação no Apache usando o
75 MySQL.
76
77 %description -l sv
78 mod_auth_mysql kan användas för att begränsa åtkomsten till dokument
79 servade av en webbserver genom att kontrollera data i en
80 MySQL-databas.
81
82 %prep
83 %setup -q -n mod_%{mod_name}-%{version}
84
85 %build
86 %{__aclocal}
87 %{__autoconf}
88 %configure \
89         --with-apxs=%{apxs} \
90         --with-mysql=%{_prefix}
91
92 %{apxs} -c -I %{_includedir}/mysql mod_%{mod_name}.c -o mod_%{mod_name}.so -lmysqlclient
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT%{_pkglibdir}
97
98 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post
104 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
105 if [ -f /var/lock/subsys/httpd ]; then
106         /etc/rc.d/init.d/httpd restart 1>&2
107 fi
108
109 %preun
110 if [ "$1" = "0" ]; then
111         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
112         if [ -f /var/lock/subsys/httpd ]; then
113                 /etc/rc.d/init.d/httpd restart 1>&2
114         fi
115 fi
116
117 %files
118 %defattr(644,root,root,755)
119 %doc README* USAGE
120 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.069678 seconds and 3 git commands to generate.