]> git.pld-linux.org Git - packages/apache-mod_auth_mysql.git/blob - apache-mod_auth_mysql.spec
5e995ad2451fa278e6e4b4c9da3382692f9761bd
[packages/apache-mod_auth_mysql.git] / apache-mod_auth_mysql.spec
1 %define         mod_name        auth_mysql
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the MySQL authentication module for Apache
4 Summary(cs):    Základní autentizace pro WWW server Apache pomocí MySQL
5 Summary(da):    Autenticering for webtjeneren Apache fra en MySQL-database
6 Summary(de):    Authentifizierung für den Apache Web-Server, der eine MySQL-Datenbank verwendet
7 Summary(es):    Autenticación vía MySQL para Apache
8 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant une base de données MySQL
9 Summary(it):    Autenticazione di base per il server Web Apache mediante un database MySQL
10 Summary(ja):    MySQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤ò»È¤Ã¤¿ Apache Web ¥µ¡¼¥Ð¡¼¤Ø¤Î´ðËÜǧ¾Ú
11 Summary(nb):    Autentisering for webtjeneren Apache fra en MySQL-database
12 Summary(pl):    Modu³ uwierzytelnienia MySQL dla Apache
13 Summary(pt_BR): Autenticação via MySQL para o Apache
14 Summary(sv):    Grundläggande autenticering för webbservern Apache med en MySQL-databas
15 Name:           apache-mod_%{mod_name}
16 Version:        4.3.9
17 Release:        0.1
18 License:        GPL
19 Group:          Networking/Daemons
20 Source0:        ftp://ftp.debian.org/debian/pool/main/liba/libapache-mod-auth-mysql/libapache-mod-auth-mysql_%{version}.orig.tar.gz
21 # Source0-md5:  9c1ecbe5fb64d4c93444311ff34bfe35
22 BuildRequires:  %{apxs}
23 BuildRequires:  apache-devel >= 2.0.0
24 BuildRequires:  apr-util >= 1:1.0
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  mysql-devel
28 Requires:       apache >= 2.0.0
29 Requires:       apache-mod_auth
30 Obsoletes:      apache-mod_%{mod_name} <= %{version}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
34 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
35
36 %description
37 This is an authentication module for Apache that allows you to
38 authenticate HTTP clients using MySQL RDBMS.
39
40 %description -l cs
41 Balíèek mod_auth_mysql slou¾í pro omezení pøístupu k dokumentùm, které
42 poskytuje WWW server Apache. Jména a hesla jsou ulo¾ena v databázi
43 MySQL.
44
45 %description -l de
46 mod_auth_mysql kann verwendet werden, um den Zugriff auf von einem
47 Web- Server bediente Dokumente zu beschränken, indem es die Daten in
48 einer MySQL-Datenbank prüft.
49
50 %description -l es
51 mod_auth_mysql puede usarse para limitar el acceso a documentos
52 servidos por un servidor web verificando datos en una base de datos
53 MySQL.
54
55 %description -l fr
56 mod_auth_mysql peut être utilisé pour limiter l'accès à des documents
57 servis par un serveur Web en vérifiant les données dans une base de
58 données MySQL.
59
60 %description -l it
61 mod_auth_mysql può essere usato per limitare l'accesso a documenti
62 serviti da un server Web controllando i dati in un database MySQL.
63
64 %description -l ja
65 mod_auth_mysql ¤Ï¡¢MySQL ¥Ç¡¼¥¿¥Ù¡¼¥¹¤Î¥Ç¡¼¥¿¤ò¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È
66 ¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ë¥É¥­¥å¥á¥ó¥È¤Ø¤Î¥¢¥¯¥»¥¹¤òÀ©¸Â¤¹¤ë¤³¤È
67 ¤¬¤Ç¤­¤Þ¤¹¡£
68
69 %description -l pl
70 To jest modu³ uwierzytelnienia dla Apache pozwalaj±cy na
71 uwierzytelnianie klientów HTTP z u¿yciem bazy danych MySQL.
72
73 %description -l pt_BR
74 Com o mod_auth_mysql você pode fazer autenticação no Apache usando o
75 MySQL.
76
77 %description -l sv
78 mod_auth_mysql kan användas för att begränsa åtkomsten till dokument
79 servade av en webbserver genom att kontrollera data i en
80 MySQL-databas.
81
82 %prep
83 %setup -q -n mod-auth-mysql-%{version}
84
85 %build
86 sed -i -e 's#/usr/bin/apxs2#%{apxs}#g' configure*
87 %configure \
88         --enable-apache2 \
89         --with-apxs=%{apxs} \
90         --with-mysql=%{_prefix}
91 %{apxs} -c -DAPACHE2 -DAPR_XtOffsetOf=APR_OFFSETOF -I %{_includedir}/mysql mod_%{mod_name}.c \
92         `%{_bindir}/apr-1-config --link-ld` `%{_bindir}/apu-1-config --link-ld` -lcrypt -lmysqlclient
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/conf.d}
97
98 libtool install mod_%{mod_name}.la $RPM_BUILD_ROOT%{_pkglibdir}
99
100 echo 'LoadModule %{mod_name}_module     modules/mod_%{mod_name}.so' > \
101         $RPM_BUILD_ROOT%{_sysconfdir}/conf.d/90_mod_%{mod_name}.conf
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post
107 if [ -f /var/lock/subsys/apache ]; then
108         /etc/rc.d/init.d/apache restart 1>&2
109 fi
110
111 %postun
112 if [ "$1" = "0" ]; then
113         if [ -f /var/lock/subsys/apache ]; then
114                 /etc/rc.d/init.d/apache restart 1>&2
115         fi
116 fi
117
118 %files
119 %defattr(644,root,root,755)
120 %doc DIRECTIVES USAGE
121 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*_mod_%{mod_name}.conf
122 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.058717 seconds and 2 git commands to generate.