]> git.pld-linux.org Git - packages/apache-mod_auth_mysql.git/blob - apache-mod_auth_mysql.spec
0903833fa0b49ee90073e7952d847f3d60c8541b
[packages/apache-mod_auth_mysql.git] / apache-mod_auth_mysql.spec
1 %define         mod_name        auth_mysql
2 %define         apxs            /usr/sbin/apxs
3 Summary:        This is the MySQL authentication module for Apache
4 Summary(cs.UTF-8):      Základní autentizace pro WWW server Apache pomocí MySQL
5 Summary(da.UTF-8):      Autenticering for webtjeneren Apache fra en MySQL-database
6 Summary(de.UTF-8):      Authentifizierung für den Apache Web-Server, der eine MySQL-Datenbank verwendet
7 Summary(es.UTF-8):      Autenticación vía MySQL para Apache
8 Summary(fr.UTF-8):      Authentification de base pour le serveur Web Apache utilisant une base de données MySQL
9 Summary(it.UTF-8):      Autenticazione di base per il server Web Apache mediante un database MySQL
10 Summary(ja.UTF-8):      MySQL データベースを使った Apache Web サーバーへの基本認証
11 Summary(nb.UTF-8):      Autentisering for webtjeneren Apache fra en MySQL-database
12 Summary(pl.UTF-8):      Moduł uwierzytelnienia MySQL dla Apache
13 Summary(pt_BR.UTF-8):   Autenticação via MySQL para o Apache
14 Summary(sv.UTF-8):      Grundläggande autenticering för webbservern Apache med en MySQL-databas
15 Name:           apache-mod_%{mod_name}
16 Version:        4.3.9
17 Release:        0.2
18 License:        GPL
19 Group:          Networking/Daemons
20 Source0:        ftp://ftp.debian.org/debian/pool/main/liba/libapache-mod-auth-mysql/libapache-mod-auth-mysql_%{version}.orig.tar.gz
21 # Source0-md5:  9c1ecbe5fb64d4c93444311ff34bfe35
22 Patch0:         %{name}-ac.patch
23 BuildRequires:  %{apxs}
24 BuildRequires:  apache-devel >= 2.0.0
25 BuildRequires:  apr-util >= 1:1.0
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  libtool
29 BuildRequires:  mysql-devel
30 BuildRequires:  rpmbuild(macros) >= 1.268
31 Requires:       apache(modules-api) = %apache_modules_api
32 Requires:       apache-mod_auth
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
36 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
37
38 %description
39 This is an authentication module for Apache that allows you to
40 authenticate HTTP clients using MySQL RDBMS.
41
42 %description -l cs.UTF-8
43 Balíček mod_auth_mysql slouží pro omezení přístupu k dokumentům, které
44 poskytuje WWW server Apache. Jména a hesla jsou uložena v databázi
45 MySQL.
46
47 %description -l de.UTF-8
48 mod_auth_mysql kann verwendet werden, um den Zugriff auf von einem
49 Web- Server bediente Dokumente zu beschränken, indem es die Daten in
50 einer MySQL-Datenbank prüft.
51
52 %description -l es.UTF-8
53 mod_auth_mysql puede usarse para limitar el acceso a documentos
54 servidos por un servidor web verificando datos en una base de datos
55 MySQL.
56
57 %description -l fr.UTF-8
58 mod_auth_mysql peut être utilisé pour limiter l'accès à des documents
59 servis par un serveur Web en vérifiant les données dans une base de
60 données MySQL.
61
62 %description -l it.UTF-8
63 mod_auth_mysql può essere usato per limitare l'accesso a documenti
64 serviti da un server Web controllando i dati in un database MySQL.
65
66 %description -l ja.UTF-8
67 mod_auth_mysql は、MySQL データベースのデータをチェックすること
68 によって、Web サーバーが提供するドキュメントへのアクセスを制限すること
69 ができます。
70
71 %description -l pl.UTF-8
72 To jest moduł uwierzytelnienia dla Apache pozwalający na
73 uwierzytelnianie klientów HTTP z użyciem bazy danych MySQL.
74
75 %description -l pt_BR.UTF-8
76 Com o mod_auth_mysql você pode fazer autenticação no Apache usando o
77 MySQL.
78
79 %description -l sv.UTF-8
80 mod_auth_mysql kan användas för att begränsa åtkomsten till dokument
81 servade av en webbserver genom att kontrollera data i en
82 MySQL-databas.
83
84 %prep
85 %setup -q -n mod-auth-mysql-%{version}
86 %patch0 -p1
87
88 %build
89 %{__aclocal}
90 %{__autoconf}
91 %configure \
92         --disable-apache13 \
93         --enable-apache2 \
94         --with-apxs2=%{apxs} \
95         --with-mysql=%{_prefix}
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
101
102 libtool install apache2_mod_%{mod_name}.la $RPM_BUILD_ROOT%{_pkglibdir}
103 rm -f $RPM_BUILD_ROOT%{_pkglibdir}/*.{l,}a
104
105 echo 'LoadModule %{mod_name}_module     modules/apache2_mod_%{mod_name}.so' > \
106         $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/90_mod_%{mod_name}.conf
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post
112 %service -q httpd restart
113
114 %postun
115 if [ "$1" = "0" ]; then
116         %service -q httpd restart
117 fi
118
119 %files
120 %defattr(644,root,root,755)
121 %doc DIRECTIVES USAGE
122 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
123 %attr(755,root,root) %{_pkglibdir}/*.so
This page took 0.059553 seconds and 2 git commands to generate.