]> git.pld-linux.org Git - packages/apache-mod_auth_kerb.git/blob - apache-mod_auth_kerb.spec
c303a51cb542bde705be014cf03ec6b5fe77aef5
[packages/apache-mod_auth_kerb.git] / apache-mod_auth_kerb.spec
1 %define         mod_name        auth_kerb
2 %define         apxs    /usr/sbin/apxs
3 Summary:        This is the Kerberos authentication module for Apache
4 Summary(pl.UTF-8):      Moduł uwierzytelnienia Kerberos dla Apache
5 Name:           apache-mod_%{mod_name}
6 Version:        5.4
7 Release:        1
8 Epoch:          1
9 License:        GPL
10 Group:          Networking/Daemons/HTTP
11 Source0:        http://dl.sourceforge.net/modauthkerb/mod_%{mod_name}-%{version}.tar.gz
12 # Source0-md5:  642b81763ad3ca81dba359cb952da5e3
13 Source1:        %{name}.conf
14 URL:            http://modauthkerb.sourceforge.net/
15 BuildRequires:  %{apxs}
16 BuildRequires:  apache-devel >= 2.0
17 BuildRequires:  gdbm-devel
18 BuildRequires:  heimdal-devel
19 BuildRequires:  rpmbuild(macros) >= 1.268
20 BuildRequires:  sed >= 4.0
21 Requires:       apache(modules-api) = %apache_modules_api
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         apacheconfdir   %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
25 %define         apachelibdir    %(%{apxs} -q LIBEXECDIR 2>/dev/null)
26
27 %description
28 This is an authentication module for Apache that allows you to
29 authenticate HTTP clients using user entries in an Kerberos directory.
30
31 %description -l pl.UTF-8
32 To jest moduł uwierzytelnienia dla Apache pozwalający na
33 uwierzytelnianie klientów HTTP z użyciem wpisów w katalogu Kerberosa.
34
35 %prep
36 %setup -q -n mod_%{mod_name}-%{version}
37
38 %build
39 %configure \
40         --without-krb4 \
41         --with-apache=%{_prefix}
42
43 %{__sed} -i -e 's/-pthread/-lpthread/' Makefile
44 %{__make}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{apachelibdir},%{apacheconfdir}}
49
50 install src/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{apachelibdir}
51 install %{SOURCE1} $RPM_BUILD_ROOT%{apacheconfdir}/20_mod_%{mod_name}.conf
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 %service -q httpd restart
58
59 %postun
60 if [ "$1" = "0" ]; then
61         %service -q httpd restart
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %doc README
67 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{apacheconfdir}/*_mod_%{mod_name}.conf
68 %attr(755,root,root) %{apachelibdir}/*.so
This page took 0.06982 seconds and 2 git commands to generate.