]> git.pld-linux.org Git - packages/apache-mod_auth_kerb.git/blob - apache-mod_auth_kerb.spec
- unified
[packages/apache-mod_auth_kerb.git] / apache-mod_auth_kerb.spec
1 %define         mod_name        auth_kerb
2 %define         apxs    /usr/sbin/apxs
3 Summary:        This is the Kerberos authentication module for Apache
4 Summary(pl):    Modu³ uwierzytelnienia Kerberos dla Apache
5 Name:           apache-mod_%{mod_name}
6 Version:        5.0
7 %define pre rc6
8 Release:        0.%{pre}.1
9 Epoch:          1
10 License:        GPL
11 Group:          Networking/Daemons
12 Source0:        http://dl.sourceforge.net/modauthkerb/mod_%{mod_name}-%{version}-%{pre}.tar.gz
13 # Source0-md5:  274edfb950af20ce6ef0ddcb7c20263a
14 Source1:        %{name}.conf
15 Patch1:         %{name}-aprfix.patch
16 URL:            http://modauthkerb.sourceforge.net/
17 BuildRequires:  %{apxs}
18 BuildRequires:  apache-devel
19 BuildRequires:  gdbm-devel
20 BuildRequires:  heimdal-devel
21 BuildRequires:  sed >= 4.0
22 Requires:       apache(modules-api) = %apache_modules_api
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
26 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)
27
28 %description
29 This is an authentication module for Apache that allows you to
30 authenticate HTTP clients using user entries in an Kerberos directory.
31
32 %description -l pl
33 To jest modu³ uwierzytelnienia dla Apache pozwalaj±cy na
34 uwierzytelnianie klientów HTTP z u¿yciem wpisów w katalogu Kerberosa.
35
36 %prep
37 %setup -q -n mod_%{mod_name}-%{version}-%{pre}
38 %patch1 -p1
39
40 %build
41 %configure
42 %{__sed} -i -e 's/-pthread/-lpthread/' Makefile
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd.conf}
48
49 install src/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
50 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf/20_mod_%{mod_name}.conf
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 if [ -f /var/lock/subsys/httpd ]; then
57         /etc/rc.d/init.d/httpd restart 1>&2
58 fi
59
60 %preun
61 if [ "$1" = "0" ]; then
62         if [ -f /var/lock/subsys/httpd ]; then
63                 /etc/rc.d/init.d/httpd restart 1>&2
64         fi
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 %doc README
70 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf/*_mod_%{mod_name}.conf
71 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.033963 seconds and 3 git commands to generate.