]> git.pld-linux.org Git - packages/apache-mod_auth_cas.git/blob - apache-mod_auth_cas.spec
- utf8
[packages/apache-mod_auth_cas.git] / apache-mod_auth_cas.spec
1 %define         mod_name        auth_cas
2 %define         apxs            %{_sbindir}/apxs
3 Summary:        Apache module: CAS
4 Summary(pl.UTF-8):      Moduł Apache'a: CAS
5 Name:           apache-mod_%{mod_name}
6 Version:        1.0.8
7 Release:        0.1
8 License:        GPL v3+
9 Group:          Networking/Daemons/HTTP
10 # svn export https://www.ja-sig.org/svn/cas-clients/mod_auth_cas/tags/mod_auth_cas-1.0.8
11 Source0:        mod_%{mod_name}-%{version}.tar.bz2
12 # Source0-md5:  2bd4117f7a8b25ade77f53c59c66944a
13 Source1:        %{name}.conf
14 URL:            https://www.ja-sig.org/svn/cas-clients/mod_auth_cas/
15 BuildRequires:  %{apxs}
16 BuildRequires:  apache-devel >= 2.2
17 BuildRequires:  rpmbuild(macros) >= 1.268
18 Requires:       apache(modules-api) = %apache_modules_api
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
22 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
23
24 %description
25 Apache CAS Authentication Module.
26
27 %description -l pl.UTF-8
28 Moduł Apache'a do uwierzytelniania poprzez CAS.
29
30 %prep
31 %setup -q -n mod_%{mod_name}-%{version}
32
33 %build
34 %{apxs} -c src/mod_%{mod_name}.c
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
39
40 install src/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
41 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %post
47 %service -q httpd restart
48
49 %postun
50 if [ "$1" = "0" ]; then
51         %service -q httpd restart
52 fi
53
54 %files
55 %defattr(644,root,root,755)
56 %doc README
57 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
58 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.077266 seconds and 3 git commands to generate.