]> git.pld-linux.org Git - packages/apache-mod_auth_cas.git/blob - apache-mod_auth_cas.spec
- BR: openssl-devel
[packages/apache-mod_auth_cas.git] / apache-mod_auth_cas.spec
1 %define         mod_name        auth_cas
2 %define         apxs            %{_sbindir}/apxs
3 Summary:        Apache module: CAS
4 Summary(pl.UTF-8):      Moduł Apache'a: CAS
5 Name:           apache-mod_%{mod_name}
6 Version:        1.0.9
7 Release:        1
8 License:        Apache v2.0
9 Group:          Networking/Daemons/HTTP
10 # svn export https://www.ja-sig.org/svn/cas-clients/mod_auth_cas/trunk
11 Source0:        mod_%{mod_name}-%{version}.tar.bz2
12 # Source0-md5:  618f13e525edb4e5e45a5daaab67ad27
13 Source1:        %{name}.conf
14 URL:            https://www.ja-sig.org/svn/cas-clients/mod_auth_cas/
15 BuildRequires:  %{apxs}
16 BuildRequires:  apache-devel >= 2.2
17 BuildRequires:  openssl-devel
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 Requires:       apache(modules-api) = %apache_modules_api
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR 2>/dev/null)
23 %define         _sysconfdir     %(%{apxs} -q SYSCONFDIR 2>/dev/null)/conf.d
24
25 %description
26 Apache CAS Authentication Module.
27
28 %description -l pl.UTF-8
29 Moduł Apache'a do uwierzytelniania poprzez CAS.
30
31 %prep
32 %setup -q -n mod_%{mod_name}-%{version}
33
34 %build
35 %{apxs} -c src/mod_%{mod_name}.c
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}}
40
41 install src/.libs/mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
42 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/90_mod_%{mod_name}.conf
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %post
48 %service -q httpd restart
49
50 %postun
51 if [ "$1" = "0" ]; then
52         %service -q httpd restart
53 fi
54
55 %files
56 %defattr(644,root,root,755)
57 %doc README
58 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*_mod_%{mod_name}.conf
59 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.086316 seconds and 3 git commands to generate.