]> git.pld-linux.org Git - packages/apache-mod_auth_any.git/blob - apache-mod_auth_any.spec
- może wrescie ktoś wykasuje to konto ?
[packages/apache-mod_auth_any.git] / apache-mod_auth_any.spec
1 %define         mod_name        auth_any
2 %define         apxs            /usr/sbin/apxs
3 Summary:        Basic authentication for the Apache Web server using arbitrary shell commands
4 Summary(cs):    Základní autentizace pro WWW server Apache pomocí shellových pøíkazù
5 Summary(da):    En autenticeringsmodul for webtjeneren Apache hvor man kan bruge vilkårlige skal-kommandoer
6 Summary(de):    Authentifizierung für den Apache Web-Server, der arbiträre Shell-Befehle verwendet
7 Summary(fr):    Authentification de base pour le serveur Web Apache utilisant des commandes shell arbitraires
8 Summary(it):    Autenticazione di base per il server Web Apache mediante comandi arbitrari della shell
9 Summary(no):    En autentiseringsmodul for webtjeneren Apache der en kan bruke skall-kommandoer
10 Summary(pl):    Podstawowy modu³ autentykacji dla Apache, u¿ywaj±cy poleceñ pow³oki
11 Summary(pt):    Um módulo de autenticação de LDAP para o servidor Web Apache
12 Summary(sl):    Osnovna avtentikacija za spletni stre¾nik Apache, z uporabo poljubnih lupinskih ukazov
13 Summary(sv):    Grundläggande autentisering för webbservern Apache med valfria skalkommandon
14 Name:           apache-mod_%{mod_name}
15 Version:        1.3
16 Release:        1
17 License:        BSD
18 Group:          Networking/Daemons
19 Source0:        ftp://ftp.itlab.musc.edu/pub/toolbox/mod_%{mod_name}/mod_%{mod_name}-%{version}.tar.gz
20 # Source0-md5:  847d209b295a02f48e9ea3d55dac652a
21 URL:            http://www.itlab.musc.edu/~nafees/mod_%{mod_name}.html
22 BuildRequires:  %{apxs}
23 BuildRequires:  apache(EAPI)-devel
24 Requires(post,preun):   %{apxs}
25 Requires:       apache(EAPI)
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _pkglibdir      %(%{apxs} -q LIBEXECDIR)
29
30 %description
31 This module allows you to use any command line program (such as
32 webNIS) to authenticate a user.
33
34 %description -l cs
35 Balíèek mod_auth_any slou¾í pro omezení pøístupu k dokumentùm, které
36 poskytuje WWW server Apache. Jména a hesla jsou kontrolována pomocí
37 jakéhokoliv pøíkazu (jeho návratovým kódem).
38
39 %description -l de
40 Mod_auth_any kann verwendet werden, um den Zugriff auf von einem Web-
41 Server bediente Dokumente zu beschränken, indem es den Rückcode eines
42 gegebenen arbiträren Befehls prüft.
43
44 %description -l es
45 Mod_auth_any puede usarse para limitar el acceso a documentos servidos
46 desde un servidor web verificando el código de retorno de un comando
47 arbitrario especificado.
48
49 %description -l fr
50 Mod_auth_any peut être utilisé pour limiter l'accès à des documents
51 servis par un serveur Web en vérifiant le code de retour d'une
52 commande spécifiée arbitraire.
53
54 %description -l it
55 Mod_auth_any può essere utilizzato per limitare l'accesso ai documenti
56 serviti da un server Web controllando il codice di ritorno di un dato
57 comando arbitrario.
58
59 %description -l ja
60 Mod_auth_any ¤ÏǤ°Õ¤Ë»ØÄꤵ¤ì¤¿¥³¥Þ¥ó¥É¤ÎÌá¤ê¥³¡¼¥É¤ò¥Á¥§¥Ã¥¯¤¹¤ë¤³¤È
61 ¤Ë¤è¤Ã¤Æ¡¢Web ¥µ¡¼¥Ð¡¼¤¬Ä󶡤¹¤ë¥É¥­¥å¥á¥ó¥È¤Ø¤Î¥¢¥¯¥»¥¹¤òÀ©¸Â¤¹¤ë¤³¤È
62 ¤¬¤Ç¤­¤Þ¤¹¡£
63
64 %description -l pl
65 Ten modu³ pozwala na u¿ycie dowolnego programu dzia³aj±cego z linii
66 poleceñ (jak np. webNIS) do autentykacji u¿ytkownika.
67
68 %description -l sv
69 Mod_auth_any kan användas för att begränsa åtkomsten till dokument
70 servade av en webbserver genom att kontrollera returkoden från ett
71 godtyckligt angivet kommando.
72
73 %prep
74 %setup -q -n mod_%{mod_name}
75
76 %build
77 %{apxs} -c src/mod_%{mod_name}.c -o mod_%{mod_name}.so
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT%{_pkglibdir}
82
83 install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post
89 %{apxs} -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
90 if [ -f /var/lock/subsys/httpd ]; then
91         /etc/rc.d/init.d/httpd restart 1>&2
92 fi
93
94 %preun
95 if [ "$1" = "0" ]; then
96         %{apxs} -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
97         if [ -f /var/lock/subsys/httpd ]; then
98                 /etc/rc.d/init.d/httpd restart 1>&2
99         fi
100 fi
101
102 %files
103 %defattr(644,root,root,755)
104 %doc docs/*
105 %attr(755,root,root) %{_pkglibdir}/*
This page took 0.059802 seconds and 3 git commands to generate.